О движке

Общая информация по движку

 Return to Introduction

DataLife Engine v.8.5 - это многопользовательский новостной движок, обладающий большими функциональными возможностями. Движок предназначен, в первую очередь, для создания новостных блогов и сайтов с большим информационным контекстом. Однако он имеет большое количество настроек, которые позволяют использовать его практически для любых целей. Движок может быть интегрирован практически в любой существующий дизайн и не имеет никаких ограничений по созданию шаблонов для него. Еще одной ключевой особенностью DataLife Engine - является низкая нагрузка на системные ресурсы. Даже при очень большой аудитории сайта нагрузка не сервер будет минимальной и вы не будете испытывать каких-либо проблем с отображением информации. Движок оптимизирован под поисковые системы, что приведет на ваш сайт дополнительных клиентов. Использование продвинутой технологии AJAX позволит вам сэкономить вам ваш трафик и трафик посетителей, а также снижает нагрузку на сервер.


Общие Возможности

DataLife Engine обладает следующими возможностями:

Общие возможности:

? Использует для хранения данных MySQL
? Минимальная нагрузка на базу данных
? Использование продвинутой технологии AJAX
? Вывод новостей, статей, да и вообще всего что угодно
? Поддержка ЧПУ (человеко-понятный URL) позволяет использовать тему статьи или любой другой текст в URL браузера, благодаря этому индексация сайта в поисковых системах будет более качественной (необходим modrewrite)
? Возможность отключения ЧПУ
? Общая статистика сайта
? Поддержка дополнительных полей (возможность использовать не только краткую и полную новость на сайте, но и имеется возможность для создания любого количества дополнительных полей различных видов для ввода информации)
? Возможность написания статей, содержащих несколько страниц
? Флуд контроль
? Автоматический фильтр слов в комментариях
? Поддержка категорий
? Возможность установки любого количества вложенных категорий
? Каждой категории можно назначить отдельный шаблон
? Автоматическое обрезание длинных слов в комментариях
? Рейтинг новостей
? Календарь
? Поиск по статьям включая дополнительные поля (подсветка найденного текста)
? Обзор непрочитанных новостей с момента последнего посещения сайта
? Возможность просмотра сколько раз была прочитана новость
? Возможность добавления статей в раздел "Избранное"
? Отсылка писем пользователям через форму на сайте
? Вывод страницы используя сжатие gzip
? Поддержка персональных сообщений между пользователями
? Поддержка нескольких языков
? Вывод популярных статей в отдельном блоке
? Возможность создания статистический страниц непосредственно через админпанель
? Возможность выбора между упрощенной регистрацией и расширенной, при выборе расширенной регистрации пользователь будет зарегистрирован только после активации аккаунта. Активация высылается по почте.
? Возможность загрузки и прикрепления файлов к новостям
? Встроенные средства защиты от несанкционированного скачивания файлов (antileech)
? RSS Импорт новостей
? RSS Информеры
? Мультиязычная поддержка новостей на сайте
? Поддержка Облака Тегов
? Автоматическая поддержка смартфонов

Возможности для посетителей сайта:

? Регистрация на сайте
? Добавление комментариев
? Изменение и удаление пользователями своих собственных комментариев
? Возможность добавления новостей со стороны посетителей
? Модерирование новостей
? Статистика по конкретному пользователю (включая рейтинг и профиль)
? Вывод различной информации для зарегистрированных посетителей и нет
? Возможность загрузки фотографии в профиле пользователя
? Возможность восстановления забытого пароля
? Возможность редактирования новости непосредственно на сайте
? Смена скинов на сайте по своему усмотрению
? Ведение закладок для новостей, и быстрый доступ к ним.
? Массовая загрузка картинок на сервер
? Просмотр и добавление видео на сайт
? Персонализация вывода рекламы для определенных групп
? Возможность загрузки большого количества картинок и файлов в один клик

Возможности админцентра:

? Добавление, редактирование и удаление новостей
? Полностью настраиваемая админпанель для различных групп пользователей
? Возможность использования двух редакторов (BBCODES или WYSIWYG)
? Антивирус проверяющий состояние файлов на предмет возможного взлома
? Редактирование пользователей
? Имеется возможность использовать смайлы и HTML код
? Неограниченное создание групп пользователей с тонкой настройкой различных прав доступа
? Возможность выставления бана для посетителей
? Средства для создания и редактирования шаблонов непосредственно в админцентре
? Возможность корректировки времени
? Возможность изменения даты публикации
? Автоматическая публикация статьи при наступлении установленного времени
? Возможность отключения календаря и архивов (для экономии ресурсов)
? Возможность фиксации новостей (будут всегда наверху, независимо от даты)
? Отключение регистрации посетителей
? Автоматическая временная приостановка регистрации при достижении максимального количества зарегистрированных пользователей
? Автоматическое уменьшение загруженных картинок с сохранением пропорций до указанных размеров
? Автоматическое удаление пользователей которые не посещали сайт заданное время
? Наложение водяных знаков на картинки
? Возможность загрузки картинок для каждой конкретной новости (при удалении новости, картинки тоже будут удаляться)
? Удобный менеджер загруженных картинок
? Оптимизацию, ремонт, создание резервной копии и восстановление базы данных можно осуществлять непосредственно из скрипта
? Поиск пользователей по IP адресам
? Удобное управление рекламными материалами.
? Быстрый поиск и замена в базе данных
? Публикация "правил" на сайте
? Создаие карты сайта для Google
? Создание фильтров для автоподстановки слов и значений

И много других полезных функций...


Список изменений

Список изменений относительно версии 8.3:

q Добавлена возможность указывать в настройках групп пользователей, категории, в которые им разрешено добавлять в новости. В случае установления этих ограничений в настройках групп, пользователи смогут добавлять новости только в назначенные категории, и ни в какие другие. При этом при добавлении будет доступен только список разрешенных категорий.
q В настройки скрипта добавлена возможность включать или отключать автоматический парсинг ссылок в тексте новостей. При включении данной возможности, все текстовые ссылки начинающиеся с http://, будут автоматически преобразованы в кликабельные ссылки.
q Добавлена корректная обработка тега PAGEBREAK в статических страницах, при выводе результатов поиска по статическим страницам.
q В настройки скрипта добавлена возможность устанавливать минимальное количество символов в комментарии, тем самым вы можете ограничить потенциальный флуд в комментариях, и исключить в комментариях малозначимые фразы, например "Спасибо" или "+1" и т.д.
q Добавлена поддержка скриптом поддержка проигрывания на сайте контейнера MKV в формате видео H.264/AAC. Тем самым вы можете размещать на сайте видео высокой четкости вплоть до разрешений Full HD, требуя при этом на 20% меньше трафика, по сравнению с обычными форматами воспроизведения видео, а также вы можете добавлять видео содержащее звук 5.1, несколько языковых звуковых дорожек, а также субтитры. Пример вы можете посмотреть на нашей странице.
q В настройки скрипта добавлена возможность, указания для загружаемых изображений, по какой стороне по умолчанию проводить создание уменьшенной копии. Вы можете указать: "По наибольшей стороне", "По ширине" или "По высоте".
q Добавлена возможность указывать для рекламных материалов на сайте время начала и время окончания показа баннеров. Данные параметры являются необязательными, и в случае если данные параметры не указаны, то баннер будет показываться неограниченное количество времени. Также вы можете по отдельности указывать, как только дату начала показа, так и только дату окончания показа.
q Изменен принцип включения режима "галереи" при показе уменьшенных картинок, данный режим теперь включается только при просмотре полных новостей, чтобы объединять показ галереи только в пределах одной новости, и не включается при выводе кратких новостей.
q Настройки наложения водяного знака на видео были перенесены из настроек скрипта в настройки видеоплееров.
q В настройки групп добавлена возможность разрешения или запрещения для группы изменять параметры загрузки картинок на сервер. Вы можете разрешить для группы возможность изменять при загрузке размеры уменьшенных копий, наложение водяного знака и т.д. Ранее такая возможность была доступна только стандартным группам не ниже статуса "Журналиста".
q В антивирус добавлен контроль изменений в javascript файлах. В случае если вы делаете снимок системы, в данный снимок вносятся также и все JS файлы, и в случае появления в них изменений, антивирус сообщит вам о их наличии.
q Добавлено Gzip сжатие javascript файлов, при включении данной возможности в настройках скрипта, все JS файлы скрипта сжимаются в gzip архивы и кешируются на сервере. Данная возможность позволяет до 70% уменьшить размер файлов и соответственно существенно ускорить загрузку веб страницы в браузер. Также вы можете использовать gzip сжатие и для CSS вашего шаблона, позднее, после релиза, мы опубликуем статью как это сделать. Данная возможность доступна только для PHP 5.1 и выше, если версия вашего PHP ниже, то данная возможность автоматически отключается.
q В целях безопасности, убрана возможность скачивать файлы бекапов БД с админпанели скрипта, скачать бекапы после создания возможно только по FTP, из папки /backup/
q Добавлена возможность массового выбора комментариев для их удаления непосредственно на сайте. Вы можете одновременно выбрать на странице несколько комментариев и их удалить. Для выбора комментариев в шаблоне comments.tpl используется тег {mass-action}, а оформление меню выбора действия выполняется классом .mass_comments_action. Массовые действия над комментариями разрешены только группам, которым в настройках разрешено удалять все комментарии.
q В админпанели скрипта добавлена возможность редактирования и удаления всех комментариев. Ранее возможность редактирования новостей была только для определенной новости.
q Добавлена возможность в админпанели скрипта, при добавлении или редактировании новостей, редактировать и удалять найденные похожие новости.
q Добавлена возможность просматривать в админпанели результаты голосований на сайте.
q В связи с тем что многие администраторы необдуманно дают возможность добавления новостей в админпанели для мало известных им людей, разрешение или запрет в настройках групп, на использование в новостях HTML, также распространяется и при добавлении новостей с админпанели. Хотя мы настоятельно рекомендуем не давать доступ в админпанели для всех подряд, кто это просит.
q Добавлена возможность для голосований на сайте устанавливать дату начала голосования и дату окончания голосования. При этом если данные параметры установлены, то голосование будет начинаться и автоматически заканчиваться в указанное время. Если они не установлены, то голосование будет показываться независимо от даты до тех пор пока оно не будет оставлено вручную в админпанели.
q Для шаблона main.tpl добавлен новый тег [static=имя страницы] текст [/static], который выводит текст указанный в данном теге при просмотре указанной статической страницы. Также добавлен противоположный ему тег [not-static=имя страницы] текст [/not-static], который выводит текст везде, кроме указанной таблице. Допускается также использовать в данных тегов имена нескольких страниц, для этого имена статических страниц необходимо перечислять через запятую.
q Добавлена поддержка регистрации пользователей с E-mail адресами, находящихся в однобуквенных доменах второго уровня. Таких почтовых доменов пока один http://i.ua
q Добавлена поддержка кода безопасности (CAPTCHA) при использовании на сайте безопасного SSL (https://) протокола.
q Добавлено кеширование таких разделов как: просмотр всех новостей пользователя и просмотр новостей по ключевому слову из облака тегов. Что ведет к снижению нагрузки на MySQL сервер.
q Внесены изменения в алгоритмы формирования кеша скрипта, в результате которых были решены проблемы с одновременным использованием каталога на разных языках, например русские буквы и английские, а также с формированием тега custom, содержащего большие списки категорий.
q Для дополнительных полей новостей добавлено использование редакторов при написании в них информации, что делает добавление информации в данные поля более быстрым и удобным. В зависимости от настроек скрипта, для дополнительных полей включаются BB редактор, либо WYSIWYG редактор. А также поле полной новости в админпанели скрипта, получило свою отдельную панель BB редактора.
q В список массовых действия при редактировании новостей, добавлена возможность проводить очистку ключевых слов для облака тегов у выбранных новостей.
q При просмотре списка новостей при их редактировании, в случае если к новости был добавлен опрос, то добавлен вывод соответствующей информационной пиктограммы, что облегчает идентификацию новостей у которых существует опрос.
q В настройки скрипта добавлена возможность указывать тип графического оформления увеличенного изображения из уменьшенной копии. Допускается выбор четырех типов: С закругленными краями и тенью, c прямыми краями и тенью, только тень, только рамка без тени. Для каждого типа допускается переназначение вида в CSS шаблона.
q Добавлена возможность принудительно переключения на мобильную версию сайта. Для этого вам необходимо разместить в вашем шаблоне ссылку http://site.ru/index.php?action=mobile Данная возможность предназначена для того чтобы пользователи, заходящие на ваш сайт с мобильного телефона могли свободно переключаться между полной и мобильной версией сайта по желанию. А также пользователи желающие экономить свой траффик могли переключаться на мобильную версию используя при этом обычный компьютер и браузер.
q Добавлена поддержка зафиксированных новостей при выводе новостей с использованием тега custom. Если новости зафиксированы в этих категориях, то и при выводе их с использованием тега custom, они также будут первыми.
q Добавлена поддержка RSS информеров в статических страницах. Вы можете добавлять теги информаров, как в текст статической страницы, так и в файлы шаблонов статических страниц.
q Добавлена поддержка рекламы, из модуля управления рекламными материалами, в статических страницах. Вы можете добавлять теги баннеров, как в текст статической страницы, так и в файлы шаблонов статических страниц.
q Переработаны механизмы создания карты сайты для поисковых систем Google и Яндекса, в результате чего добавлена поддержка создания карт сайта, содержащих более 50 000 новостей. Если на сайте опубликовано более 50 000 новостей, то карта будет разбита на несколько файлов и создан индексный файл для карт.
q Добавлена возможность устанавливать снятие новости с публикации на главной странице по истечении срока действия публикации новости, также добавлена возможность снятия фиксации новости, по истечении указанного периода.
q Добавлена поддержка подсветки строк в списке редактирования новостей, статических страниц и пользователей, скрипт подсвечивает строки на которых находится курсор мышки, что облегчает навигацию и ориентацию в списке при редактировании большого количества элементов в списке.
q Внесены многочисленные оптимизации в исходный код административной панели, обеспечивающие одинаковое отображение панели в различных браузерах.
q Исправлена проблема при которой не отображались дополнительные поля профилей пользователей при просмотре списка последних комментариев.
q Исправлена проблема при которой неверно учитывались результаты опроса в новостях, при большом количестве вариантов ответов и голосований.
q Исправлена проблема при которой происходила аварийное завершение скрипта, если при редактировании пользователя его E-mail менялся на уже существующий у другого пользователя.
q Исправлена проблема при которой неверно конвертировались кавычки в доп. полях профиля и они автоматически конвертировались в HTML сущности при повторном редактировании.
q Исправлена проблема в браузере Опера с автоматической функцией транслитерации латинских букв в кириллицу, используемой в BB редакторе.
q Исправлена проблема с некорректной транслитерацией имен файлов содержащих в названии кириллицу при массовой загрузке их на сервер.

Список изменений относительно версии 8.2:

q Добавлен новый плеер для проигрывания flv видеофильмов. Новым плеер обладает рядом преимуществ по сравнению со старым, а именно: Уменьшенный в два раза вес самого плеера, что существенно ускоряет его загрузку в браузер, новый плеер обладает улучшенной прогрессивной загрузкой видео, что улучшает качество воспроизведения видео на относительно медленном интернет соединении, а также добавлена поддержка проигрывания новых форматов файлов с расширением mov, 3gp, f4v.
q Добавлена возможность для посетителей сайта подписываться на комментарии к определенным новостям. Для этого пользователю при добавлении комментария к новости необходимо выбрать соответствующую галочку и в случае, если к новости будут добавлены другие комментарии, то он получит соответствующее уведомление на E-mail. Включение или отключение данного модуля производиться в настройках скрипта, а также в настройках групп вы можете установить, для каких групп пользователей разрешена подписка на комментарии к новостям.
q Администратор имеет возможность отписать всех пользователей от всех новостей, для этого предусмотрена соответствующая кнопка на главной странице в админпанели. Также пользователь может самостоятельно отписать самого себя от всех новостей, для этого ему необходимо в своем профиле на сайте выбрать соответствующее действие.
q Добавлена возможность при подключении сторонних модулей в шаблонах сайта передавать в качестве параметра к модулям результаты выполнения шаблонных тегов скрипта. Например при добавлении в шаблон полной новости конструкции {include file="engine/modules/mymod.php?param={news-id}"}, вы можете передавать вашему стороннему модулю в качестве параметра ID новости и т.д. Вниманию разработчиков: Передаваемые в скрипт параметры, это GET параметры, соответственно при выборе передаваемых тегов вы должны учитывать ограчения GET строки, другими словами вы не можете передать в качестве параметра содержимое полной новости к примеру.
q В фильтр слов добавлена возможность выбора действия, в случае нахождения слова в добавляемом тексте. Вы можете выбрать действие при котором слово, находящиеся в тексте, будет заменяться на указанное, а можете выбрать действие, при котором добавление текста полностью отклоняться, и новость или комментарий не будут добавлены на сайт, а пользователю будет выведено соответствующее уведомление о том что его текст содержит недопустимые к публикации слова.
q Для дополнительных полей профилей пользователей, добавлен новый тип поля "Список (select)", что позволяет выбирать посетителями дополнительную информацию о своем профиле из определенного списка. Например выбирать свой пол и т.д.
q Добавлена поддержка подключения сторонних модулей не только в стандартных файлах шаблона, но и в сторонних файлах шаблона, которые вы подключаете в основные файлы. Например: в шаблоне main.tpl вы можете подключить сторонний шаблон {include file="mytemplate.tpl"}, а в стороннем файле шаблона использовать подключение сторонних модулей {include file="engine/modules/mymod.php"}.
q Добавлена поддержка режима "галереи" при показе удаленных изображений, опубликованных в теге [img], которые были автоматически уменьшены согласно настроек скрипта.
q Добавлен вывод аннотаций и описаний при увеличении уменьшенных удаленных изображений опубликованных в теге [img]. Вывод аннотаций осуществляется аналогичным образом, как и для загруженных изображений в теге [thumb].
q Добавлена полная поддержка линейки PHP версии 5.3.x и выше, устаревшие PHP функции, которые больше не поддерживаются новыми версиями PHP, были заменены на аналогичные актуальные функции.
q Добавлен вывод ключевых слов из облака тегов для новости, при просмотре новостей находящихся в закладках у посетителя. А также добавлен вывод в этих новостях даты редактирования и причин редактирования, если таковые данные имеются.
q В админпанели добавлен новый раздел настройки видеопроигрывателей используемых на сайте. В данном разделе вы можете настроить размеры плееров, а также настроить цветовое оформление флеш плеера, предназначенного для проигрывания flv и mp4 формата
q Добавлен новый плеер для проигрывания mp3 аудиофайлов, для данного плеера также действуют цветовые настройки, которые были установлены для видеопроигрывателя.
q В настройки скрипта для более удобного визуального восприятия добавлено отображение текущего времени сервера с учетом коррекции при указании настроек коррекции временных зон.
q Добавлена поддержка мультикатегорий при обработке тега [category=x] текст [/category] и просмотре полной новости. Если новость опубликована в нескольких категориях одновременно, то при проверке тега [category=x] текст [/category] будут учтены все категории новости, а не только первая категория по списку как ранее.
q В логику шаблона addcomments.tpl внесены изменения облегчающие создание этого шаблона. Добавлен новый тег {editor} который выводит полностью редактор BBCODES или WYSIWYG соответственно настройкам скрипта. Для оформления BBCODES редактора введен класс .editor. Соответственно из шаблона убрана обработка тегов {wysiwyg}, {bbcode}, [not-wysywyg], {text}.
q Аналогично комментариям, для персональных сообщений (шаблон pm.tpl), также введено использование тега {editor} для вывода редактора, при помощи которого будет производиться написание персональных сообщений.
q В настройки групп добавлена возможность указывать для размеров аватара не только максимальную величину какой либо из сторон, но и указаывать непосредственно ширину и высоту загружаемого аватара, например 100x100 при этом аватар при загрузке будет пропорционально обрезан непосредственно под укаазаные размеры сторон.
q Добавлена возможность при восстановлении пароля с сайта осуществлять сброс блокировки по IP. Ранее блокировка по IP снималась одновременно вместе с восстановлением и сбросом пароля. Теперь же при восстановлении пароля на E-mail приходит две ссылки: одна на восстановление пароля, другая на сброс блокировки по IP, установленной в настройках профиля и для сброса блокировки, больше не нужно одновременно с этим сбрасывать пароль.
q После восстановления и генерации посетителем нового пароля на сайте добавлена отправка пользователю E-Mail сообщения содержащего его новые данные: логин и новый пароль. Теперь посетителю необязательно сразу куда-либо копировать сложный пароль или запоминать его.
q Убран вывод выбора сортировки новости при просмотре профиля пользователя.
q В настройки скрипта добавлена возможность включения или отключения объединения комментариев от одного пользователя, добавляемых пользователем к одной новости друг за другом.
q Добавлена возможность удаления пользователя непосредственно при редактировании его данных, тем самым для того чтобы удалить пользователя вам нет необходимости заходить в раздел редактирования пользователей, и вы можете его удалить, вызвав его профиль из любого раздела сайта, где это предусмотрено.
q Добавлена возможность, при отправке сообщений через обратную связь, отправлять также и текст, содержащий HTML теги, ранее скрипт автоматически удалял любой HTML. Форматирование текста при этом не осуществляется и сообщение находится в обычном текстовом формате, поэтому данное нововведение будет полезно в том случае если посетители сайта сообщают о каких либо проблемах и необходимо описать например HTML.
q При редактировании новостей в админпанели скрипта, добавлена возможность поиска новостей, не принадлежащих ни одной категории.
q В настройки групп добавлена возможность разрешения или запрета использования HTML кода при добавлении новостей с сайта. Несмотря на то, что скрипт не допускает появления в новостей зловредного кода, многие владельцы сайтов не хотят видеть в оформлении новостей HTML код. В случае запрета пользователи могут оформлять новости исключительно с использованием BB тегов, а все форматирование, сделанное при помощи HTML, будет удалено.
q Добавлена возможность задавать разное оформление при выводе имени группы пользователя. Для этого в настройках групп добавлен префикс и суффикс имени группы, которые будут выводиться до и после имени группы соответственно. Для данный настроек разрешено использование HTML кода для задания форматирования.
q Добавлена поддержка новых правил форматирования для RSS "Яндекс новости", согласно новым правилам, форматирование полной новости для тега yandex:full-text, больше не удаляется, а лишь корректно экранируется.
q В шаблоны краткой и полной новости добавлен новый тег [day-news] текст [/day-news], который выводит ссылку на все новости, опубликованные в тот же день что и данная новость. Данный тег например можно использовать совместно с тегом {date}.
q Добавлена поддержка пользовательской сортировки новостей, при просмотре пользователем своих закладок.
q Добавлена поддержка тегов {date}, {date=формат даты}, {views} при поиске в статических страницах и выводе результатов этого поиска.
q Добавлена проверка на добавление дублирующихся имен для статических страниц, а также автоматическая транслитерация имени статической страницы, что исключает добавление страницы с неверным или не поддерживаемым именем.
q При создании бекапа базы данных из админпанели добавлено добавление к сформированному имени файла бекапа уникального префикса, что делает невозможность поиска методом перебора файлов с резервными копиями БД в папке, где они расположены.
q При обновлении карты сайта для поисковых систем Google и Яндекс, добавлено также обновление и даты редактирования новостей, вместо даты создания новости. Ранее дата изменялась только в случае была изменена дата новости. А также добавлена ссылка на автоматические уведомление поисковой системы Google о наличии новой версии карты сайта.
q Обновлен до актуальной версии WYSIWYG редактор
q Исправлена проблема при которой, при удалении новости, она не удалялась из закладок пользователя, в результате чего данная информация излишне накапливалась в БД.
q Исправлена ошибка при которой неверно обрабатывался тег [code] при редактировании новости, если включен редактор BBCODES и отключен автоматический перенос строк.
q Исправлена проблема с использованием тега {%user%} при использовании его в массовой рассылке сообщений, при которой скрипт обращался к посетителем с использованием одного имени.
q Исправлена проблема с публикацией кавычек при добавлении описаний к уменьшенным копиям изображений.
q Исправлена проблема с невозможностью редактировать пользователя при редактировании новостей, если логин состоит из русских символов.
q Исправлена проблема некорректного автоматического формирования ключевых слов для метатегов, в случае если текст подвергся типографской обработке.
q Исправлены обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 8.0:

q Добавлена функция типографской обработки текста, данная функция позволяет автоматически подготовить русский текст к веб-изданию. Например кавычки будут заменены на елочки, выставлены правильные апострофы в именах, использование длинных тире вместо дефисов, перед предлогами будут вставлены неразрывные пробелы, обработка вложенных кавычек и многое другое. Этот инструмент не является полноценной заменой ручного труда верстальщика, но он может сократить этот труд до 90%, что весьма удобно.
q Расширены возможности тега {include file="mytemplate.tpl"}. Данный тег позволяет теперь не только подключать файлы шаблона, но и подключать в шаблоне сторонние модули для DLE, а также сторонние скрипты не имеющие отношения к DLE. Например для подключения стороннего модуля в шаблоне вы можете использовать тег {include file="engine/modules/mymod.php"} результатом работы тега будет выполнение скрипта mymod.php, находящегося в папке engine/modules/. Также вы можете запускать скрипты с параметрами, например {include file="engine/modules/mymod.php?param=value1¶m2=value2"}, тем самым вы можете создавать модули которые могут управляться непосредственно из шаблона и в зависимости от разных параметров, выводить разную информацию. Использование данного метода подключения модов, позволяет при обновлении скрипта в будущем на новую версию не переустанавливать модули. Они будут автоматически сами подключены из шаблона. Использование данного тега возможно во всех файлах шаблонов. В целях общей безопасности скрипта, единственным ограничением по подключению файлов является запрет на нахождение файле в папке, доступной для записи. Например подключаемый мод, не может находится в папке шаблонов например. Более подробно о данном подключении можно прочитать в документации по скрипту.
q Добавлена возможность интегрировать сторонние модули в панель управления скриптом, без внесения каких либо изменений в файлы скрипта. Для этого была добавлена дополнительная таблица в базу данных, для хранения информации о стороннем модуле. Более подробно о формате таблице вы сможете прочитать в документации по скрипту.
q Добавлена автоматическая поддержка безопасного режима PHP (SafeMode), при загрузке изображений на сервере. Благодаря этой поддержки папки больше не нужно создавать вручную, используя FTP менеджер.
q Добавлена возможность быстрого редактирования профиля пользователя при редактировании его новости в админпанели. Тем самым вы можете удалить или забанить пользователя добавившего новость, не заходя в раздел редактирования пользователей.
q В панели управления скриптом добавлены функции проверки соответствия вашего сервера мининимальным требованиям скрипта. Ранее такая проверка проводилась только во время инсталяции скрипта. Новая возможность позволяет скрипту автоматически диагностировать возможные неполадки после переноса скрипта на другой сервер, когда установка скрипта не производится.
q При загрузке изображений добавлены функции автоматического контроля возможных ошибок. И в случае возникновения проблем с загрузкой выводится сообщение те только о невозможности загрузки файлов, но и причина по которой произошла проблема. Тем самым в большинстве случаев вы можете самостоятельно устранить проблему, без обращения в тех поддержку.
q Для тега спойлера добавлены графические индикаторы, отображающие открыт или закрыт скрытый текст. Графические изоборажения находятся в шаблонах сайта, поэтому для каждого шаблона имеется возможность настроить изображения.
q В шаблоны краткой и полной новости (shortstory.tpl, fullstory.tpl) добавлены следующие теги: - выводит текст в тегах если данная новость зафиксирована, [not-fixed] текст [/not-fixed] - выводит текст в тегах если данная новость не была зафиксирована. Тем самым благодаря новым тегам, вы можете делать различное оформление новостей на сайте при выводе зафиксированных новостей.
q В настройки скрипта добавлена возможность включения или отключения затемнения общего фона сайта, при увеличении уменьшенного изображения до оригинального. Для задания фона используется класс CSS .highslide-dimming
q Добавлен новый режим "Галлерея" при просмотре уменьшенных изображений загруженных на сайте к новости. Данный режим включается в настройках скрипта. При включении данного режима на оригинальном изображении выводится меню навигации, которое позволяет запускать слайдшоу из картинок, показывать следующее или предыдущее изображение и т.д.
q Добавлена возможность задания аннотаций и описаний к уменьшенным изображениям. При задании для тега thumb собственного описания, при увеличении изображения до оригинального, данное описание будет показано в удобном формате под изображением.
q Наверное самое ожидаемая возможность. Добавлена возможность задания для уменьшенной копии загружаемого изображения не только размер одной из сторон при превышении которой будет создаваться уменьшенная копия, но и непосредственно размеры сторон (ширину и высоту) самого уменьшенного изображения. При этом пропорции изображения будут сохранены, а само изображения обрезано под указанные размеры. Более того, в случае если какая либо из сторон оригинального изображения меньше указанных размеров, то изображение будет пропорционально увеличено до указанного размера. Примеры работы данной функции вы можете увидеть выше, опубликованы три картинки разных размеров и ориентации, при этом они были автоматически уменьшены до прямоугольных размеров 200x200. Данное нововведение, совместно с двумя указанными выше, позволяет организовывать в ваших новостях красивые фотогалереи из загруженных изображений.
q При входе в админпанель скрипта добавлена возможность выбора используемого языка. Тем самым пользователи пользующиеся административной панелью могут сами выбирать на каком языке будут ее использовать.
q Добавлена возможность назначать категориям собственный метатег Title.
q Добавлена возможность использования при массовой рассылке сообщений тега {%user%} в тексте сообщения, который будет заменен на логин получателя в сообщении, или на полное имя, если пользователь его указывал в своем профиле. Если в настройках скрипта включено использование поля BCC для рассылки, то тег будет заменен на слово: Пользователь
q В фильтр слов добавлена возможность назначения области поиска для слова. Вы можете назначить чтобы замена для слова производилась везде, либо только в новостях, либо только в комментариях.
q Шаблонные теги [aviable=...] текст [/aviable] и [not-aviable=...] текст [/not-aviable] получили глобальную поддержку во всех файлах шаблонов, а не только для основного main.tpl и шаблонов новостей. Теперь вы можете использовать данные теги в абсолютно любых файлах шаблонов.
q Форматирование и вывод комментариев выделен в отдельный универсальный класс. Данное нововведение касается в первую очередь разработчиков сторонних модулей. Благодаря новому классу можно организовывать комментарии не только для новостей, но и для собственных модулей. Также при добавлении новых тегов в комментарии, достаточно внести изменения в один файл, а не в три как было ранее.
q Внесены изменения в MySQL запросы скрипта, в результате чего была снижена нагрузка на базу данных при большом объеме базы данных.
q При просмотре мобильной версии сайта отключен вывод рекламных материалов назначенных для показа между краткими новостями.
q Добавлено автоматическое скрытие ссылок "отправить E-Mail" и "написать ПС" при просмотре профиля пользователя, если для посетителя в настройках групп данные возможности были запрещены.
q В модуль восстановления забытого пароля были добавлены новые механизмы безопасности. А именно был добавлен новый алгоритм генерации контрольного ключа по алгоритму SHA1, а также был добавлен контроль проверки количества попыток генерации нового пароля по контрольному ключу, допускается только одна попытка генерации нового пароля, после чего контрольный ключ становится недействительным. Тем самым модуль восстановления пароля получил 100% устойчивость к восстановлению пароля методом перебора.
q В модуле поиска добавлена подсветка искомого текста в дополнительных полях новости.
q Добавлена возможность назначать тип текста при публикации статических страниц, в зависимости от выбранного типа будут применяться различные параметры для форматирования текста, также вы можете выбрать тип текста без фильтрации и изменений, который позволяет напрямую публиковать в тексте статической страницы javascript код и любой HTML код, а также редактировать текст без конвертации в BB теги. Возможность публиковать страницы без фильтрации имеют только пользователи, находящиеся в администраторской группе.
q Добавлена возможность добавлять / редактировать дату создания статической страницы.
q Добавлены новые возможности для поиска и сортировки статических страниц в админпанели скрипта.
q Добавлена постраничная навигация для статических страниц. Тем самым существенно облегчается процесс поиска и редактирования.
q Добавлена возможность массового управления статическими страницами в админпанели в разделе редактирования страниц. Вы можете выбрать несколько страниц одновременно и установить для них текущую дату или очистить количество просмотров или полностью удалить выбранные страницы.
q В шаблоны для статических страниц добавлен новый тег {date} - который выводит дату создания страницы в формате установленном в насройках скрипта, а также добавлен новый тег {date=формат даты}, который выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y, H:i} выведет полную дату и время.
q В настройки скрипта добавлена возможность автоматического закрытия новости для комментирования по истечении определенного количества дней, после ее публикации. Тем самым с использованием данной настройки вы можете избежать флуда на вашем сайте в старых и неактуальных новостях.
q Внесены изменения в всплывающее меню редактирования новости на сайте. В случае если пользователю разрешить редактирование собственных комментариев, но при этом не разрешить доступ к админпанели, то для пользователя будет автоматически скрываться пункт "Полное редактирование", тем самым вы можете давать пользователям права для быстрой и незначительной правки новости, без допуска в админпанель.
q Изменена система единой авторизации на домене второго уровня его поддоменах, теперь логинится на сайте и разлогиниваться можно на любом поддомене или домене второго уровня, необязательно при этом проводить авторизацию или разлогинивание только на домене второго уровня как ранее. Действия по авторизации на любом поддомене будут автоматически распознаваться и на других поддоменах, а также на домене второго уровня.
q Проведен небольшой рестайлинг административной панели скрипта, а также панель управления скриптом была оптимизирована для корректного отображения в новой версии браузера Safari 4.
q В дистрибутив добавлен абсолютно новый стандартный шаблон. Данный шаблон является полностью валидным и соответствующим стандарту XHTML 1.0
q Добавлены новые функции в DLE API, а также расширены возможности ранее существовавших функций. Подробнее о новых функциях вы сможете прочитать в документации по скрипту.
q Обновлен до актуальной версии WYSIWYG редактор. Просмотреть изменения в редакторе можно по адресу http://tinymce.moxiecode.com/js/tinymce/changelog.txt. А также вес редактора был сжат на 40%, тем существенно увеличена скорость его загрузки в браузер.
q Исправлена проблема, при которой в случае сбоя массовой рассылки, на странице рассылки не сохранялось количество успешно отправленных сообщений и писем.
q Исправлена проблема, при которой при использовании BB тега [flash] не выставлялись размеры по высоте для браузера Firefox.
q Исправлена проблема при которой во время просмотра версии для печати удалялось содержимое тегов [pаge=...] текст [/pаge]
q Исправлена проблема, при которой не загружались файлы и изображения при использовании массовой загрузки, если новость редактируется другим пользователем и он хотел добавить в новость другие файлы или изображения.

Список изменений относительно версии 7.5:

q Итак первая и самая ожидаемая возможность это возможность настраивать доступ к различным разделам админпанели. Теперь вы можете в настройках групп назначить для пользователей, находящихся в этой группе, доступ к различным разделам админпанели. И для того чтобы дать пользователю ту или иную возможность необязательно его делать администратором. Более 17 разделов админпанели теперь имеют возможность назначения им доступа для других групп. Исключение составляют критически важные с точки зрения безопасности разделы, такие как настройка скрипта, бекапы базы данных, настройка групп пользователей, поиск и замена в БД. Для данных разделов доступ имеют только пользователи из администраторской группы.
q В связи с тем что в админпанели появилась возможность распеределение доступа между различными группами, был проведен полный аудит безопасности разделов, в целях предотвращения выхода пользователя за пределы доступа. Была пересмотрена безопасность и фильтрация входящих данных. Однако мы настоятельно рекомендуем давать доступ только пользователям которым вы несомненно доверяете, т.к. админпанель предоставляет обширные возможности по управлению сайтом.
q Пользователи находящиеся в группе, которым разрешено управление пользователями в админпанели, не могут удалять или редактировать пользователей, находящихся в администраторской группе. Администраторами могут управлять только администраторы.
q Из настроек скрипта убран пункт настроек комментариев: "Использовать поле e-mail как URL". Данный пункт был введен еще с самых первый версий скрипта, когда проблема спама и раскрутки сайтов путем спама не была актуальной. Теперь же в данном пункте нет никакой необходимости и в поле e-mail для комментариев, можно добавлять только e-mail.
q Теги [group=id]текст[/group] и [not-group=id]текст[/not-group] получили глобальную поддержку во всех файлах шаблонов, а не только для основного main.tpl и шаблонов новостей. Теперь вы можете использовать данные теги в абсолютно любых файлах шаблонов.
q Срок жизни кеша RSS информеров установлен в один час, поэтому если ваш сайт редко обновляется и автоматическая очистка его кеша происходит редко, то RSS информеры на сайте будут все равно обновляться с периодичностью в один час, или когда изменится состояние кеша вашего сайта.
q В модуль фильтра слов добавлена возможность указания производить поиск и замену с учетом регистра слова или без, что добавляет еще больше гибкости в фильтр
q В список массовых действий при редактировании новостей добавлена возможность обнуления счетчика просмотров для выбранных новостей.
q В список массовых действий при редактировании новостей добавлена возможность очистки рейтинга для выбранных новостей.
q Добавлена возможность добавления для статических страниц метатега title, тем самым вы можете вручную задавать заголовок страницы по своему усмотрению, в случае оставления этого заголовка пустым, он будет автоматически сформирован на основе описания страницы.
q В модуле RSS импорта добавлена возможность очистки списка новостей. Например в данном RSS потоке не появилось никаких новостей, которые вы хотите опубликовать на сайте, то вы просто нажимаете "Очистить список" и данные новости больше не будут показываться в списке новостей при последующем RSS импорте.
q В настройки скрипта добавлена возможность включать или отключать показ аудио и видео материалов сайта при просмотре мобильной версии сайта с мобильного телефона.
q Добавлена возможность в настройках скрипта включать или отключать форматирование текста при просмотре мобильной версии сайта. В случае отключения форматирования из текста новости будет удален весь HTML код, за исключением ссылок и переноса строк.
q В календаре добавлена возможность выделять текущий день. Для этого используется класс .day-current
q Добавлена возможность указывать для новости не только срок ее действия, но задавать действие, которое будет выполнено по истечении этого срока. Новость может быть удалена либо снята с публикации на сайте.
q Добавлена возможность добавления для новостей метатега title, тем самым вы можете вручную задавать заголовок при просмотре полной новости по своему усмотрению, в случае оставления этого заголовка пустым, он будет автоматически сформирован на основе заголовка новости.
q Увеличена скорость работы крона, а также существенно снижена потребляемая память по отработке действий над новостями срок действия которых истек.
q В настройки скрипта добавлена возможность разрешать или запрещать для индексации поисковиками ссылок на версии для печати. В случае если вы запрещаете их индексацию то к этим ссылкам будут добавлены параметры noindex, nofollow. Однако это не означает что уже проиндексированные страницы исчезнут из поисковых систем, роботы не будут только индексировать новые страницы.
q В настройки скрипта добавлена возможность разрешать или запрещать для индексации поисковиками ссылок которые публикуют ваши пользователи в комментариях. Например вы хотите разрешить вашим пользователем публикации ссылок в комментариях, но не хотите чтобы поисковики индексировали эти ссылки, то эта настройка для вас. При запрете индексирования к ссылкам будут добавлены параметры noindex, nofollow.
q Добавлена возможность размещения в корне сайта страниц c расширением .html не относящиеся к скрипту, ранее все имена в корне с таким расширением были зарезервированы для статических страниц. Теперь скрипт резервирует имена только в том случае если файла с таким именем не существует на сервере.
q Добавлена возможность разрешения или запрета пользователям в настройках групп использования обратной связи. Но при этом в случае запрета группе они смогут использовать обратную связь только для связи с администрацией сайта, а не полностью будет введен запрет на этот модуль, но при этом не смогут отправлять E-mail другим зарегистрированным пользователям.
q Добавлена возможность массового управления пользователями в админпанели в разделе редактирования пользователей. Вы можете выбрать несколько пользователей одновременно и изменить их группу, забанить этих пользователей как на неограниченный так и на ограниченный срок с указанием причины, удалить комментарии этих пользователей, удалить самих пользователей. Доступ к массовому управлению пользователями имеют группы, которые имеют доступ к редактированию пользователей. При этом если группа в которой находится пользователь не является администраторской, то он не может удалить, забанить или изменить группу администраторам сайта.
q Для шаблонов краткой и полной новости, а также для шаблона комментариев добавлен новый тег {date=формат даты}, который выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время.
q В шаблон для комментариев добавлен новый тег {login}, который выводит логин автора комментария без каких либо ссылок и меню.
q В шаблон для комментариев добавлен новый тег [profile] текст [/profile], который выводит текст заключенный в теге в виде ссылки на профиль пользователя оставившего комментарий.
q Добавлен новый тег [youtubе=ссылка на страницу с видео] при написании новостей. Данный тег предназначен для публикации видео на сайте с таких видеохранилищ как youtube.com и rutube.ru. В данном теге вы просто указываете URL страницы видеохранилища где размещено видео, скрипт автоматически распознает тип видеохранилища и вставит нужный HTML код для просмотра видео. Примеры можно посмотреть на нашей странице примеров видеоплееров, поддерживаемых скриптом.
q Добавлен новый тег [flash=ширина,высота] Путь к ролику [/flash], предназначенный для вставки флеш роликов в формате swf.
q Добавлена возможность при загрузке флеш роликов на сервер к новостям, помимо ссылки на скачивание ролика, вставлять также флеш тег на проигрывание этого ролика на сайте.
q Добавлена поддержка апострофов в метатегах, заголовках и описании сайта, тем самым добавлена полная поддержка таких языков как украинский и французкий в скрипте, включая поисковую оптимизацию.
q Внесены небольшие корректировки в функции отправки почты, решающие проблемы с отправкой почты на некоторых Windows системах, при использовании стандартной функции PHP mail().
q Исправлена проблема при которой в некоторых случаях происходила потеря HTML тегов в ссылках после редактирования.
q Исправлена проблема при которой можно было дублировать правила для фильтра по: IP, Логину или E-Mai
q Исправлена проблема с сортировкой новостей в теге {custom} при чередовании разных тегов c выводом новостей из разных категорий с разными настройками сортировки в категориях.
q Обновлена до актуальной версии библиотека Highslide JS
q Обновлен до актуальной версии WYSIWYG редактор. Просмотреть изменения в редакторе можно по адресу http://tinymce.moxiecode.com/js/tinymce/changelog.txt
q Добавлены функции API для стандартизированного написания модификаций, совместимых с различными версиями скрипта, а также для интеграции скрипта с другими скриптами. На данный момент API содержит функции для работы с пользователями. Будущем его возможности будут расширятся.
q Исправлены все обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 7.3:

q Добавлена полная автоматическая поддержка просмотра вашего сайта с смартфонов. При заходе на ваш сайт скрипт автоматически определит что на сайт зашли с мобильного телефона и переключит шаблон скрипта на специально подготовленную облегченную версию шаблона, а также при необходимости для экономии трафика уберет из новостей все изображения. Для поддержки мобильных версий сайта необходимо наличие специальной папки шаблона smartphone. На данный момент поддерживаются практически все известные модели, если ваш смартфон не определяется скриптом, то вам необходимо сообщить об этом на форуме.
q В настройки скрипта добавлен новый раздел, в котором вы можете настраивать автоматическую поддержку смартфонов вашим сайтом. В данном разделе вы можете включить или отключить автоматическую поддержку смартфонов, а также включить или отключить изображения в новостях при просмотре вашего сайта с мобильного телефона.
q Добавлена возможность вложения спойлеров друг в друга.
q Добавлена возможность при массовой загрузке файлов также указывать различные параметры на странице загрузки файлов. Вы можете указывать какого размера создавать уменьшенную копию, по какой стороне ее уменьшать, создавать ли уменьшенную копию и т.д.
q Добавлен вывод ключевого слова из облака тегов в мета тег title, при просмотре всех новостей по этому ключевому слову.
q Добавлена улучшенная и полная поддержка Adobe Flash Payer 10.
q Добавлена полная совместимость модуля массовой загрузки файлов на сервер с браузерами Firefox, Opera и Chrome.
q В настройки группы добавлена возможность запрещать для определенных групп загрузку аватаров на сервер. Для этого в настройках максимального размера аватара, укажите 0 или -1.
q Добавлена поддержка тега [cоde] текст [/code] в статических страницах.
q Из календаря на сайте убрана ссылка на месяцы которые еще не наступили, что предотвращает появление несуществующих страниц при индексации сайта в поисковой системе Google
q Добавлена функция предварительного просмотра при создании и редактировании статических страниц, а также правил сайта.
q Добавлена поддержка версий для печати для статических страниц. Для просмотра версии для печати используется шаблон static_print.tpl. Для формировании ссылки на версию для печати в шаблоне статической страницы используются теги [print-link] текст [/print-link]
q Добавлена возможность загружать для статических страниц не только картинки, но и различные другие файлы, расширения которых указаны в настройках скрипта
q При просмотре статической страницы скрипт отдает для поисковых систем дату создания статической страницы, либо дату редактирования страницы в качестве даты создания документа HTML
q Изменен принцип формирования "версии для печати" для новостей. Если большая новость разбита на страницы, то в версии для печати выводится вся новость целиком, а не только одна страница как было ранее.
q В настройки групп добавлена возможность указывать максимальное количество символов в подписи, которую посетитель может добавить на сайте
q В настройки групп добавлена возможность указывать максимальное количество символов в краткой информации о себе.
q Улучшена система контроля изменения IP адреса. При включении данного контроля, скрипт осуществляет контроль не изменившегося IP адреса, а контроль подсети, тем самым если у вас динамический IP и произошел разрыв интернет соединения, то после повторного соединения и получения нового IP адреса от вашего провайдера из той же подсети, скрипт не будет проводить автоматического разлогинивания на сайте. Автоматическое разлогинивание будет произведено только в том случае если измениться подсеть.
q Добавлены новые превентивные меры по устранению "мусора" из комментариев и профиля пользователя. Если в настройках группы запрещена публикация в комментариях или в профиле кликабельных ссылок или картинок, то в случае если пользователь все равно добавляет их с использованием тегов [url] или [img], в таком случае комментарий будет отклонен полностью, также будет отклонена и информация добавляемая в профиль пользователя. Также на недопустимые символы фильтруются поля "Полное имя" и "Место жительства".
q Добавлена новая возможность активации скрипта в ручном режиме, например если на вашем сайте запрещены исходящие соединения и скрипт не может автоматически соединится с нашим сервером для активации. Теперь не нужно отправлять нам запрос на активацию скрипта, все необходимые инструкции по активации скрипт предложит вам самостоятельно и вы сможете получить специальный код сайта, введя который ваш скрипт активируется при отсутствии интернет соединения с нашим сервером.
q Исключено появление в облаке тегов тех тегов, назначенных для новостей, которые еще не прошли модерацию и не опубликованы на сайте.
q В облако тегов добавлен вывод подсказки при наведении курсора на тег о том сколько новостей относится к данному тегу.
q Добавлен вывод ключевых слов из облака тегов в результатах поиска по сайту.
q Добавлен вывод информации о редактировании новости при выводе результатов поиска по сайту. Для этого в шаблоне searchresult.tpl добавлено использование тегов: [edit-dаte] текст [/edit-date] выводит текст если новость была отредактирована, {edit-date} выводит дату редактирования новости, {editor} выводит логин пользователя, отредактировавшего новость, [edit-reаson] текст [/edit-reason] выводит текст если при редактировании была указана причина редактирования, {edit-reason} выводит причину редактирования новости
q Снижена нагрузка на сервер при просмотре последних комментариев на сайте, при условии что для группы нет скрытых для просмотра разделов.
q В модуль "Поиск и Замена" добавлен выбор поиска и замены ключевых слов из облака тегов.
q Добавлена сортировка по алфавиту в модуле "Фильтр слов" для более удобного и быстрого поиска нужного слова в списке, при большом количество слов в фильтре
q Добавлена поддержка плейлистов при проигрывании видео в флеш плеере в формате .flv, для публикации нескольких видеороликов, которые будут поочередно проигрываться, просто перечисляйте их URL через запятую
q Изменен плеер для проигрывания аудио файлов в формате MP3, теперь используется аналогичный плеер, что и для проигрывания видео. Пример плеера можно посмотреть на нашей странице.
q Добавлена поддержка плейлистов при проигрывании аудио файлов в формате MP3, тем самым вы можете формировать и публиковать собственные подкасты. Для публикации нескольких аудио файлов, которые будут поочередно проигрываться, просто перечисляйте их URL через запятую
q Добавлена постраничная разбивка новостей согласно настройкам скрипта при просмотре профиля пользователя и его новостей ожидающих модерации.
q Изменен принцип работы настройки "Автоматическое изменение размера для удаленных изображений". Данная настройка применяется теперь не для всех изображений находящихся в теге [img], а только для картинок находящихся на чужих серверах, а не на собственном.
q Улучшена совместимость скрипта с различными настройками серверного ПО, в частности касающихся настроек magic quotes
q Обновлен WYSIWYG редактор до актуальной версии. В данной версии исправлены некоторые ошибки в работе редактора.
q Исправлена проблема при которой на некоторых кодировках и при определенных настройках сервера могла возникать проблема с экранированием кавычек при добавлении или редактирировании с использованием технологии AJAX.
q Исправлена проблема при которой не происходило автоматической авторизации пользователя на сайте, сразу после его регистрации
q Исправлена проблема, при которой гости не могли изменить шаблон на сайте, происходило автоматическое возвращение шаблона по умолчанию.
q В модуле создания карт сайта для Google и Yandex исправлена проблема при которой в карте появлялись ссылки на новости срок публикации которых еще не наступил, в случае если они были опубликованы на будущее время.
q Исправлены все обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 7.2:

q Добавлена полностью автоматическая поддержка припаркованных к скрипту доменов. Например вашим основным доменом является http://site.ru/ который и прописан в настройках скрипта, вы припарковали к этому домену новый домен http://mirror.ru/, теперь при заходе на домен http://mirror.ru/ все ссылки которые существуют на странице и ведут на http://site.ru/ будут автоматически заменены на http://mirror.ru/
q Добавлена возможность автоматического цитирования сообщений при переписке в персональных сообщениях, если в качестве редактора используется WYSIWYG редактор.
q Оптимизированы запросы и улучшено быстродействие модуля просмотра последних комментариев на базах данных имеющих большое количество зарегистрированных пользователей на сайте.
q Обновлена на актуальную версию версию библиотека Highslide
q Обновлен WYSIWYG редактор до актуальной версии. В данной версии исправлены некоторые ошибки в работе редактора.
q В модуле регистрации добавлена проверка логина по фильтру запрещенных логинов при проверки доступности логина через AJAX.
q Также в модуле регистрации добавлена предварительная проверка посредством JavaScript правильность заполнения формы пользователем еще до отправки данных на сервер.
q Добавлены RSS потоки для отслеживания всех новостей определенного автора. Ссылка на RSS поток выглядит следующим образом: http://site.ru/user/имя пользователя/rss.xml - при включенном ЧПУ, http://site.ru/engine/rss.php?subaction=allnews&user=имя пользователя - при отключенном ЧПУ.
q В шаблон просмотра профиля пользователя (userinfo.tpl) добавлены теги [rss] тект [/rss] которые публикуют ссылку в профиле на RSS поток всех новостей пользователя. Также при просмотре профиля для браузеров автоматически формируются мета теги на данный RSS поток.
q Добавлен новый Flash плеер для проигрывания .flv файлов. В отличие от старого плеера, в новом добавлена также поддержка H.264 кодека, соответственно данный плеер также позволяет проигрывать .mp4, .m4v, .m4а файлы. Также для плеера вы можете создать картинку предосмотра первого кадра либо любую другую картинку. Для этого используйте для публикации видео тег [vidео=http://site.ru/sample.flv|http://site.ru/preview.jpg]. Пример нового плеера можно посмотреть на нашей странице.
q Добавлено добавление водяного знака на видеофайлы в формате .flv которые проигрываются во флеш плеере на сайте. Включение или отключение добавления водяного знака осуществляется в настройках скрипта. Пример видео с водяным знаком вы также можете посмотреть на нашей странице.
q Добавлено добавление ключевых слов для облака тегов при добавлении новости с сайта, обычными посетителями с сайта.
q В настройки скрипта добавлена возможность разрешения или запрета на добавление ключевых слов для облака тегов, при добавлении новостей с сайта.
q Внесены изменения в вывод новостей по ключевым словам облака тегов. Теперь выводятся только новости, имеющие полное совпадение с ключевыми словами, а не все новости имеющие похожие вхождения.
q Изменен принцип сортировки новостей при просмотре всех последних новостей на сайте. Новости сортируются по дате независимо от того что установлено в настройках скрипта.
q Усложнен алгоритм формирования кода безопастности (CAPTHA), тем самым существенно затрудняется распознавание картинки спамботами.
q Добавлена полная поддержка браузера Google Chrome JavaScript'ом используемым в DLE.
q В стилях добавлена полная поддержка браузера IE8.
q Изменен принцип вывода на страницу модуля "Архив сайта". Так ка данный блок со временем становится слишком длинным, то теперь выводятся не все месяцы сразу, а только последние 6 месяцев, остальные выводятся по клику "Показать весь архив".
q Переработаны MySQL запросы предназначенные для авторизации пользователя на сайте, в связи с чем была снижена нагрузка на MySQL сервер.
q В шаблон опроса (poll.tpl) в новостях добавлены следующие теги: [voted] текст [/voted] которые выводят текст в тегах если пользователь уже проголосовал в опросе, также добавлены теги [not-voted] текст [/not-voted] которые выводят текст в тегах если пользователь еще не проголосовал в опросе. Тем самым расширен вывод различной информации к опросам в новостях в зависимости от ситуации. Например можно скрывать кнопки голосований после того как пользователь проголосовал или например выводить рекомендации и просьбы если еще не проголосовал.
q Внесены изменения в просмотр персональных сообщений на сайте, в случае если нет персональных сообщений, выводится соответствующее уведомление, а не пустой список сообщений как ранее.
q В фильтр слов добавлена возможность устанавливать тип поиска и замены данного слова, вы можете выбрать искать ли любое вхождение данного словосочетания, или производить замену только в том случае если совпадает только слово целиком. Тем самым данный фильтр можно успешно одновременно применять как для бана нежелательных или матерных слов, так и для автоматической подстановки нужных слов или значений только для определенных слов.
q В настройки скрипта в раздел оптимизации добавлена возможность включать или отключать фиксацию новостей на сайте. Тем самым в случае отключения данной возможности скрипт будет использовать сокращенные запросы к БД, снижая тем самым нагрузку на БД.
q В технологию AJAX была добавлена расширенная поддержка различных локальных кодировок, все данные передаются в кодировке UTF-8, а потом уже автоматически конвертируются во все известные кодировки.
q Добавлена поддержка нового тега в новостях [spоiler] текст [/spoiler], который скрывает указанный в теге текст и показывает его при клике на него. Данный тег может использоваться в двух вариантах: [spоiler=Заголовок] текст [/spoiler] выводит собственный заголовок по щелчку на который будет показан скрытый текст, а также возможно использование сокращенного варианта [spоiler] текст [/spoiler] в таком случае будет использоваться стандартный заголовок "Показать / Скрыть текст". Для настройки стиля этого тега используются классы: .title_spoiler - заголовок спойлера, .text_spoiler - текст спойлера.
q Наличие тега {bbcode} в шаблоне addcomments.tpl не является больше обязательным условием, вы можете удалять панель BB кодов из шаблона и это не будет вызывать JS ошибки.
q Немного видоизменена вставка BB кодов, все коды вставляются в один клик, одновременно вставляются как открывающие, так и закрывающие теги, что должно улучшает скорость написания текста.
q Добавлена массовая загрузка изображений и файлов на сервер. Вы можете одновременно выбрать все файлы которые хотите загрузить на сервер, вся процедура занимает один клик. Процесс загрузки файлов отображается динамически на странице без ее перезагрузки. Хотим сразу вас предупредить, что загрузка изображений их обработка (уменьшение, водяные знаки и т.д.) это все ресурсоемкие процессы, поэтому если вы ожидаете, что платя за хостинг 1 доллар в месяц, вы сможете одновременно загружать сотни файлов, то это заблуждение, количество файлов которые сможет одновременно обработать ваш сервер ограниченно и все упирается в мощности вашего сервера или тарифного плана на хостинге.
q В настройки скрипта добавлена возможность установления ограничения на максимальный размер загружаемого на сервер файла.
q В настройки скрипта добавлена возможность ограничивать максимальное количество файлов, которые пользователь может выбрать и загрузить на сервер при массовой загрузке.
q Исправлена ошибка, при которой в карте сайта для Google генерировалась ссылка для правил на сайте с использованием в URL адресе внутренних переменных скрипта.
q Исправлена ошибка, при которой при использовании в дополнительных полях новостей типа "Список" значений с апострофом, эти значения сбрасывались при редактировании новостей.
q Исправлена проблема с отображением всплывающих уведомлений о новом персональном сообщении, на браузерах IE с использованием опреденных типов верстки шаблона без объявления DOCTYPE документа.
q Исправлены все обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 7.0:

q В скрипт добавлен абсолютно новый WYSYWIG редактор. Причиной смены редактора стало нежелание разработчика старого редактора развивать и поддерживать свой скрипт, тем самым он просто безнадежно устарел. Поэтому было принято решение перевести DLE на использование TinyMCE WYSIWYG редактора. Что дает это вам? Благодаря мощному и качественному API в редактор были качественно внедрены все специфические теги DLE, такие как leech, video, audio. Новый редактор генерирует более правильный, компактый и валидный код. Обладает гораздо лучшей совместимостью с различными браузерами. В редактор нами была добавлена поддержка GZIP сжатие исходного кода, благодаря чему удалось существенно сжать исходный код и добится очень быстрой загрузки редактора в браузер. Также в редакторе реализована поддержка проверки орфографии на многих языках одновременно, в том числе и русского языка. Проверка проходит с использованием технологии AJAX и словарных баз данных с сайта google.com
q Добавлена поддержка в языковых пакетах смена языка и для WYSIWYG редактора. При смене языка также автоматически изменяется и язык WYSYWIG редактора. Как подключить новый язык для редактора в языковых файлах DLE, будет описано нами дополнительно после выхода релиза.
q Добавлена поддержка WYSIWYG редактора при быстром редактировании комментариев с помощью технологии AJAX, если на сайте включено добавление комментариев с использованием WYSWYG редактора, то и быстрое редактирование происходит также с использованием WYSIWYG редактора.
q Добавлена поддержка WYSIWYG редактора при быстром редактировании новостей на сайте при помощи технологии AJAX. Какой из редакторов будет использоваться на сайте для быстрого редактирования можно назначить в настройках скрипта.
q Добавлен новый модуль "Облако тегов". Несмотря на то что я лично считаю такие модули безполезными, но огромная популярность данной технологии как неотьемлемой части Веб 2.0 заставили меня реализовать данную возможность в DLE. Добавление и управление облаком тегов происходит очень и очень просто, вы просто вводите ключевые теги новости через запятую при добавлении или редактировании новости. Для вывода облака тагов в основном шаблоне используется тег {tags} в шаблоне main.tpl. В основом шаблоне выводятся только 40 самых популярных и часто встречающихся тегов. При переходе по ссылке в облаке тегов скрипт выводит все новости, содержащие данное ключевое слово. В случае если в базе данных более 40 тегов, то дополнительно выводится ссылка на просмотр всех тегов, для вывода на сайте всего облака тегов используется шаблон tagscloud.tpl. Модуль облака тегов является полностью кешируемым, независимо от настроек скрипта. При обновлении сайта со старых версий незабудьте включить данный модуль в настройках скрипта в разделе оптимизации.
q В шаблоны краткой и полной новости (shortstory.tpl, fullstory.tpl) добавлены следующие теги: [tаgs] текст [/tags] выводит текст если новость содержит ключевые слова, назначенные для облака тегов, {tags} выводит кликабельные ключевые слова новости, назначенные для облака тегов, при переходе по этим ссылкам выводятся все новости, содержащие данные ключевые слова.
q Увеличена поддержка тегов в RSS информерах. Добавлено использование тегов: {category} - выводит категорию в которой опубликована новости в RSS потоке, {author} - выводит автора новости, {date} - выводит дату новости, при этом формат даты можно задать в настройках информера, для каждого информера.
q Улучшены методы автоматической блокировки спам программ, которые используются для автоматического массового добавления новостей на сайт. Используются новые механизмы динамической случайной генерации необходимых полей, поэтому даже зная алгроритм защиты обойти ее крайне затруднительно. Также в настройки скрипта добавлена возможность включения или отключения данной защиты.
q Добавлена отдача 404 ошибки для поисковых систем при просмотре удаленных статических страниц.
q Обновлена до актуальной версии библиотека Highslide, при этом существенно уменьшен код, тем самым увеличена скорость загрузки страницы и быстродействие. Добавлено динамическое изменение размера всплывающего уведомления о новом персональном сообщении, а также исправлены некоторые ошибки и улучшена совместимость с различными браузерами.
q Введены новые механизмы защиты от спамботов при регистрации пользователей на сайте.
q Добавлена возможность устанавливать в настройках групп пользователей показ кода безопасности (CAPTHA) при добавлении новостей с сайта, раньше эту возможность можно было включить в настройках скрипта для всех, теперь обязательный ввод кода безопасности для определенных групп пользователей при добавлении новостей с сайта можно отключить.
q Добавлена возможность в настройках групп, разрешать или запрещать пользователям публикацию картинок в комментариях или их использование в подписи.
q Добавлена возможность запрещать определенному пользователю оставлять комментарии или публиковать новости на сайте. Запрет на публикацию новостей или комментариев устанавливается в админпанели при редактировании профиля пользователя. Вы можете запретить также как публикацию комментариев так и новостей одновременно. Запрет может быть временным на определенное количество дней, либо на неограниченный срок. В отличие от полного бана на сайте, данные опции разрешают просматривать сайт, но лишают пользователя определенных привилегий по общению на сайте.
q Добавлена отправка E-Mail уведомлений с сайта при получении пользователем персонального сообщения, рассылка уведомлений включается в настройках скрипта, текст сообщения назначается в шаблонах E-Mail уведомлений.
q Немного улучшена система Gzip сжатия контекта, улучшена совместимость с некоторыми браузерами а также улучшена совместимость с различными настройками сервера, а также немного ускорена скорость работы.
q Исправлено формирование ссылки на просмотр всех новостей пользователя и комментариев в его профиле. Если у пользователя нет новостей или комментариев то данные ссылки становятся некликабельными, что существенно снижает в поисковых системах ошибочных 404 страниц с сообщением что нет новостей или комментариев.
q Добавлена возможность предоставления посетителю сайта самостоятельно изменять порядок сортировки новостей на сайте, для этого добавлены новые теги для шаблона main.tpl. Допустима сортировка по дате, популярности, посещаемости, комментариям, алфавиту. Сортировка выбирается как по возрастанию, так и по убыванию. Для каждого из разделов сайта пользователь может назначить свою собсвенную сортировку, например для главной отдельно, для категорий отдельно, при просмотре новостей за определенную дату также отдельно. Скрипт сохраняет порядок сортировки за пользователем на время всей сессии до закрытия им браузера. Поддержка этих тегов включается в настройках скрипта в разделе оптимизации. Включение навигации при помощи AJAX, автоматически отключает поддержку данных тегов, т.к. невозможно поддерживать назначение сортировки для различных разделов, т.к. страница браузера не перегружается при навигации по страницам через AJAX.
q Добавлена возможность смены автора публикации при редактировании новостей в админпанели. Возможность изменять автора новости имеют только администраторы сайта, другие пользователи изменить автора публикации не могут.
q В шаблоны краткой и полной новости добавлен тег {full-link} предназначенный для вывода полного постоянного адреса новости.
q Добавлена поддержка скриптом нового плеера для проигрывания видео: DivX Web Player (http://www.divx.com/divx/windows/webplayer/). Данный в отличии от Windows Media Player, новый плеер от компании DivX специально оптимизирован для просмотра потокового видео, а также позволяет проигрывать на сайте ролики HD качества. Для просмотра видео с использованием нового плеера посетителям необходимо установить плагин для браузера http://download.divx.com/player/DivXWebPlayerInstaller.exe Также вебмастера которые используют для показа видео на сайте новый плеер, могут бесплатно получить от разработчиков DivX серийный номер для кодека DivX Pro, обычная стоимость которого составляет 14,99 Евро, подробнее можно прочитать на странице разработчиков http://www.divx.com/divx/windows/webplayer/. Новый плеер используется для при вставке тега [vidео=http://site.ru/sample.avi] Расширения файлов должны быть .avi либо .divx также для плеера вы можете создать картнику предосмотра первого кадра либо любую другую картинку. Для этого используйте для публикации видео тег [vidео=http://site.ru/sample.avi|http://site.ru/preview.jpg]. Пример нового плеера можно посмотреть на нашей странице.
q Добавлен новый модуль "Правила на сайте". В данном модуле в админпанели вы можете написать правила вашего сайта, а также включить показ правил сайта перед регистрацией пользователя, в данном случае посетитель перед тем как начать процедуру регистрации должен будет принять данные правила. Помимо вывода правил сайта при регистрации, вы также можете разместить данные правила отдельной статической страницей, для общей информации посетителей. Для этого используются ссылки в шаблоне http://site.ru/rules.html при включенном ЧПУ и http://test.dle-news.ru/index.php?do=rules при выключенном ЧПУ.
q Добавлена возможность блокировать для регистрации определенные Логины или E-Mail адреса. Вы можете блокировать для регистрации логины и E-Mail как целиком так и по маске, например: admin* или *@mail.ru, где звездочка это любое количество символов. Находящиеся в фильтре логины или E-Mail не могут быть использованы для регистрации. При этом вы можете блокировать как на неограниченный срок, так и на определенный период, а также можете указывать причину данной блокировки.
q Добавлено сохранение параметров выставленных в расширенном поиске при редактировании новостей, при возврате к списку новостей после осуществления над ними массовых действий.
q Добавлена поддержка кавычек в админпанели скрипта при использовании модуля поиска и замены текста в базе данных.
q Добавлено отслеживание скриптом даты редактирование новости и логина пользователя отредактировашего новость, а также при этом для новости можно указать причину редактирования новости.
q Для отображения на сайте информации о редактировнии новости в шаблоны краткой и полной новости добавлены следующие теги: [edit-dаte] текст [/edit-date] выводит текст если новость была отредактирована, {edit-date} выводит дату редактирования новости, {editor} выводит логин пользователя, отредактировавшего новость, [edit-reаson] текст [/edit-reason] выводит текст если при редактировании была указана причина редактирования, {edit-reason} выводит причину редактирования новости.
q При просмотре полной новости скрипт отдает для поисковых систем дату создания новости либо дату редактирования новости в качестве даты создания документа HTML.
q Исправлена ошибка при загрузке изображений к статическим страницам приводящая к появлению в списке загруженных файлов изображений, загруженных к новостям.
q Исправлена ошибка при которой, после назначения нового логина пользователю в разделе редактирования уже существующего логина, происходила MySQL ошибка и некорректное изменение логина.
q Исправлена ошибка при которой не происходила проверка уникальности имени категории в URL при редактировании категории.
q Внесены изменения в систему рейтинга новостей и опросы. Не принимаются больше голоса пользователей, чьи IP адреса небыли установлены скриптом достоверно, например при использовании прокси серверов, которые не передают IP посетителя.
q Исправлена ошибка при которой обычный посетитель мог выбирать накладывать или нет водяной знак на загружаемое изображение, несмотря на то что администратор четко назначает наложение водяного знака на изображение.
q Оптимизировано отображение админпанели при работе на дисплеях с большими разрешениями. При использовании больших разрешений резиновый дизайн автоматически отменяется и используется фиксированный размер страницы, что значительно улучшает восприятие админпанели и работу на больших дислеях с большими расширениями экрана.
q Внесено более 30 незначительных исправлений и оптимизаций в код скрипта предназначенных для повышения стабильности работы скрипта, а также для увеличения быстродействия.

Список изменений относительно версии 6.7:

q Для более быстрого и понятного восприятия настройки групп пользователей в админпанели были разбиты на тематические вкладки.
q Добавлена возможность оставления пустым адрес домашней страницы сайта. В данном случае скрипт будет автоматически определять где он установлен и использовать соответствующие пути. Данное нововведение полезно при использовании припаркованных доменов или одновренной работе сайта в локальной сети и интернете, т.к. посетитель всегда будет оставатся в пределах домена на который он зашел и не будет при навигации по сайту переходить на домен, прописанный в настройках скрипта.
q Добавлена возможность загрузки изображений на сервер для создаваемых или редактируемых статических страниц. При удалении статических страниц загруженные изображения также автоматически удаляются.
q В настройки групп пользователей добавлена возможность разрешать или запрещать загрузку изображений на сервер. Тем самым теперь возможно проводить более тонкую настройку кому разрешено загружать картинки а кому нет.
q В настройки групп пользователей добавлена возможность разрешать или запрещать загрузку различных файлов на сервер. Тем самым теперь возможно проводить более тонкую настройку кому разрешено загружать не только картинки, но и различные файлы на сервер.
q Добавлена возможность, при добавлении новостей с сайта, загружать не только изображения на сервер, но и другие файлы, которые разрешены администратором сайта к загрузке, при условии что для данной группы разрешена загрузка файлов. Тем самым ваши посетители смогут при добавлении новости не только загрузить к ней картинки, но например и видео материалы.
q Добавлена поддержка скриптом кавычек в модуле "Фильтр слов" для искомых словосочетаний.
q На главной странице админпанели добавлена ссылка на редактирование новостей, ожидающих модерации, при этом при переходе по этой ссылке в списке новостей будут только новости, которые ожидают модерации. Также добавлено сохранение параметров выставленных в расширенном поиске при возврате к списку новостей после редактирования новости.
q Добавлена возможность в настройках групп, разрешать или запрещать пользователям использование подписи в комментариях.
q Добавлена возможность в настройках групп, разрешать или запрещать пользователям использование кликабельных ссылок в комментариях, профиле или персональных сообщениях. В целях предотвращения спама, вы можете разрешать публиковать ссылки только проверенным группам пользователей.
q Добавлена возможность указывать в настройках профиля несколько IP адресов или подсетей с которых разрешена авторизация на сайте под данным логином. Тем самым вы можете указать сразу несколько безопасных подсетей, например домашнюю подсеть и рабочую. Максимально вы можете указать 15 IP адресов.
q Добавлена возможность просмотра всех последних добавленных новостей, независимо от того опубликованы они на главной или нет. Данная возможность полезна для сайтов, которые публикуют на главной далеко не все новости и много новостей не попадают на главную страницу. Посмотр всех новостей осуществляется по адресу http://site.ru/lastnews/ при включенном ЧПУ и http://site.ru/index.php?do=lastnews при выключенном ЧПУ.
q Улучшенна система кеширования сайта, добавлено кеширование таких действия как просмотр последних новостей, просмотр каталога, просмотр новостей за определенный день.
q Существенно увеличена скорость работы скрипта при просмотре страниц с краткими новостями и последних комментариев, а также существенно снижена нагрузка на MySQL сервер при этом. Данная оптимизация была достугнута путем снятия запросов к MySQL серверу для подсчета общего количества новостей при формировании навигации по страницам.
q Добавлены новые механизмы защиты сайта от программ, предназначенных для автоматического добавления новостей на сайты.
q Добавлена возможность выбирать и вставлять большое количество загруженных на сервер картинок одним кликом при добавлении новостей.
q По многочисленным пожеланиям изменен принцип формирования и показа навигации по страницам новостей. Применяется такой же принцип как и при редактировании новостей в админпанели.
q Изменена панель навигации по комментариям в новости. Теперь выводится не полный список всех страниц, а также как и в новостях по 10 страниц. Тем самым навигация стала еще более удобной в новостях где очень много комментариев.
q При редактировании пользователя в админпанели добавлен вывод IP этого пользователя, а также ссылка на поиск других пользователей имеющих аналогичный IP адрес.
q В настройки скрипта добавлена возможность назначения порядка сортировки новостей при просмотре каталога. Тем самым критерий сортировки новостей при просмотре каталога больше независит от общих настроек для новостей.
q В настройки скрипта добавлена возможность установления количества найденных похожих новостей при просмотре полной новости на сайте.
q Внесены изменения в модуль отправки писем сайта, исправляющие проблемы с кирилицей в некоторых почтовых клиентах.
q Добавлена возможность выбора типа ссылки ЧПУ для полной новости. Всего доступно три варианта: C указанием категорий в URL, без указания категорий и старый тип, который использовался ранее, с использованием даты в URL.
q Добавлено автоматические обновление счетчика новостей у пользователя чьи новости удаляются скриптом автоматически, если истек срок публикации новости.
q Добавлена возможность быстрого поиска похожих новостей при добавлении или редактировании новости в админпанели, тем самым значительно облегчается процесс модерирования большого количества новостей. Поиск похожих новостей осуществляется с использованием технологии AJAX.
q В админпанель при редактировании новостей добавлена возможность массового назначения текущей даты для выбранных новостей.
q Добавлена возможность ограничения максимального количества новостей, которые посетители сайта могут добавлять на модерацию.
q Исправлена ошибка в фильтре слов, приводящая к появлению некорректных тегов в новости при редактировании, если слово в фильтре предназначено для удаления.
q Исправлена ошибка при которой при просмотре категории у которой собственные параметры сортировки новостей, также происходило переназначение настроек сортировки и для тега {custom ...}
q Исправлены все обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 6.5:

q Существенно расширены мультимедийные возможности скрипта. Добавлена возможность загружать файлы на сервер, не только для защищенного скачивания, но и для проигрывания на сайте. Скрипт автоматически распознает какой файл был загружен на сервер, и если данный файл является видефайлом или аудиофайлом, то предлагает добавить ссылку на скачивание файла или на его проигрывание. (Внимание необходимо заменить файл .htaccess в папке uploads/files/ на аналогичный файл из дистрибутива.).
q Добавлена поддержка скриптом воспроизведения Flash видео файлов (.flv) Для вставки флеш видеофайла также используется тег [videо=http://site.ru/video.flv] Скрипт автоматически распознает тип файла и если используется обычный AVI файл, подключаетя Windows Media Payer. Если используется флеш видео, то подключается Flash Player. Пример плеера вы можете увидеть на нашем сайте.
q Добавлена поддержка скриптом воспроизведения MP3 файлов. Для вставки файла и проигрования используется тег в новостях [аudio=http://site.ru/music.mp3]. Пример плеера вы можете увидеть на нашем сайте.
q Исправлены проблемы с отображением уменьшенных изображений в новостях, которые опубликованы в виде дополнительных колонок с использованием тега {custom}
q Добавлено использование плавного увеличения не только для уменьшенных копий загруженных картинок на сервер, но и для внешних картинок, опубликованных тегом [img], размеры который ограничены в настройках скрипта.
q Добавлено значение по умолчанию для тега {category-icon}, если иконка для категории не задана, то данный тег использует путь /templates/папка шаблона/dleimages/no_icon.gif
q В модуль рассылки сообщений добавлена возможность указания с какого пользователя начать рассылку сообщений, что является очень удобной возможностью если рассылка была по каким либо причинам прервана.
q В модуль рассылки писем добавлена возможность установки интервала между отправками писем, если у вашего хостера стоит ограничение на количество отправляемых писем за определенный промежуток времени, то вы можете установить рассылку согласно эти лимитам.
q Добавлена возможность установки количества отправляемых писем за один проход в модуле массовой рассылки сообщений.
q В тег [aviable=....] добавлен новый параметр catalog, для отображения информации при просмотре каталога.
q Добавлено использование технологии AJAX при написании комментариев с использованием WYSIWYG редактора, ранее добавление комментариев через AJAX было доступно только для BB редактора.
q Добавлена поддержка тега скрытого текста hide в статических страницах.
q Исправлены проблемы с отображением полной новости при RSS экпорте определенной категории в систему Яндекс новости.
q В настройки скрипта добавлена возможность указания максимального количества символов в добавляемых на сайте комментариях.
q Добавлена возможность массового назначения символьного кода для новостей при редактировании в админпанели.
q Увеличена скорость обработки шаблонов и снижено потребление оперативной памяти.
q Исправлена ошибка в формировании URL для новостей в модуле Google Sitemap.
q Внесены изменения в работу модуля "Фильтр слов" обратная конвертация слов при редактировании новости производится только в том случае, если это слово или словосочетание появилось в новости, вследствии работы фильтра слов.
q В настройки скрипта добавлена возможность указания причины временного отключения сайта, чтобы не вносить эту информацию каждый раз в шаблон. Для этого необходимо добавить тег {reason} в шаблон offline.tpl
q Изменен метод работы ссылки на редактирование новости. Если профиль пользователя просматривает модератор или администратор и в его профиле находятся новости на модерации, то ссылка на редактирование будет вести в админпанель, а не на редактирование на сайте.
q Добавлена возможность удаления новостей непосредственно с сайта, незаходя при этом в админпанель. Данной возможностью обладают пользователи, имеющие право на редактирование всех новостей.
q В модулль Google Sitemap добавлена поддержка новой схемы 0.9, а также добавлено раздельное указание приоритета для новостей, категорий и статических страниц.
q В админпанели при редактировании новостей, добавлены новые механизмы для поиска новостей по различным критериям, также добавлена возможность ручной сортировки новостей по различным параметрам.
q Внесены изменения в модуль регистрации новых пользователей, позволяющие блокировать DDOS атаки на почтовый сервер.
q Добавлены новые превентивные меры обеспечения безопасности скрипта, призванные обеспечить безопасность в случае невнимательности администраторов или других пользователей, при проведении потенциально опасных операций на сайте, когда злоумышленник пытается обманным путем или путем подмены URL завести вас на выполнение на сайте потенциально опасных операций. Например все ссылки на удаление комментариев являются уникальными для каждого пользователя, которые невозможно подделать, и при несовпадении уникального для каждого пользователя кода, скрипт автоматически блокирует работу, и т.д. по всем потенциально опасным операциям на сайте.
q Добавлено использование цифровой контрольной подписи на все действия в админпанели, тем самым полностью исключается возможность заставить в случае невнимательности администратора выполнить нежелательные или незапланированные действия, т.к. все ссылки на выполнения операций в админпанели для каждого пользователя являются уникальными.
q Введен запрет на использование динамических изображений в новостях, данный запрет введен целью предотвращения запуска PHP/CGI скриптов.
q Введен запрет на использование кликабельных ссылок в новостях или комментариев на собственную админпанель, данный запрет введен целью предотвращения увода невнимательного администратора или модератора на выполнение потенциально небезопасных действий в админпанели. Несмотря на то что пункт 27 позволяет предотвратить действия злоумышленника, данный запрет предназначен для сторонних модулей, не использующих контрольно-цифровую подпись пользователя.
q Исправлены все обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 6.3:

q Исправлены небольшие проблемы с совместимостью с MySQL 5.xx при регистрации новых пользователей.
q Исправлена ошибка, при которой производилось автоматическое отключение вывода архива сайта, при отключении календаря.
q Изменен алгоритм вывода даты у новостей и комментариев. Например если новость или комментарий были добавлены сегодня или вчера, то они выводятся в формате: "Сегодня, 12:34" или "Вчера, 12:34". В противном случае дата выводится в формате указанном в настройках скрипта.
q Полностью переработан RSS экспорт на сайте. Добавлена возможность настраивать параметры экспорта из настроек скрипта. Также экспорт не использует больше шаблон rss.tpl необходимый формат формируется автоматически.
q Добавлена возможность отключения RSS экспорта новостей в настройках скрипта, если вы не хотите использовать данную возможность, то можете отключить ее, тем самым будете экономить трафик сайта и предотвратите RSS граббинг ваших новостей.
q Добавлена возможность выбора типа экспорта главного RSS канала сайта http://dle-news.ru/rss.xml вы можете экспортировать в него либо все новости, либо только опубликованные на главной странице.
q В настройки скрипта добавлена возможность указания количества новостей, которые необходимо посылать в RSS поток.
q Добавлена возможность выбора формата для RSS экспорта новостей. Есть три типа: первый тип это простой экспорт, при выборе этого типа вы сохраняете все преимущества RSS экспорта, но при этом из потока автоматически удаляется все форматирование текста, а также картинки, передается только сама суть новости, тем самым вы экономите траффик посетителей и усложняете RSS граббинг ваших новостей, т.к. те кто будет получать новости из вашего канала, будут получать только текст без форматирования. Второй формат это полный экспорт, при котором в поток будут передоватся ваши новости с сохранением полного форматирования и стилистики, т.е. как это было раньше. И последний формат экспорта, это передача ваших новостей в соответствии со спецификацией формата Яндекс новости, т.е. поток будет полностью соответствовать требованиям Яндекса, если вы хотите транслировать свои новости на их сайт.
q Добавлено кеширование RSS экспорта, тем самым снижена нагрузка на MySQL сервер, т.к. этот модуль не использует запросов к MySQL серверу.
q В связи с приобретением лицензии на одну очень интересную разработку (http://vikjavev.no/highslide/) было полностью изменено отображение оригинальной копии загруженного на сайт изображения. Отображение картинок производится в одном окне браузера, путем плавного увеличения. Пример вы можете посмотреть в этой новости, кликнув на уменьшенные копии загруженных изображений. В связи с тем что все новости хранятся в базе данных уже готовом, сформированном формате, то новая технология будет использоватся только в новых добавленных новостях. Если вы просто отредактируете старую новость, картинки в них будут увеличиваться также с использованием новой технологии.
q Изменено отображение всплавающего окна уведомления о получении новых персональных сообщений. При отображении уведомления используются мягкие тени, работающие во всех браузерах.
q Добавлена возможность при загрузке изображений на сервер, также вставить по одному клику оригинальное изображение, если для этого изображения была создана уменьшенная копия.
q В модуль поиска добавлена возможность поиска определенного текста во всех комментариях. Кто не в курсе, то раньше поиск производился только в комментариях зарегистрированных пользователей.
q Улучшена стабильность скрипта на некоторых NT системах.
q Существенно расширена общая статистика сайта. Добавлен вывод количества опубликованных новостей за сутки, неделю, месяц (теги для шаблона stats.tpl {news_day}, {news_week}, {news_month} соответственно). Добавлен вывод количества добавленных комментариев за сутки, неделю, месяц (теги для шаблона stats.tpl {comm_day}, {comm_week}, {comm_month} соответственно). Добавлен вывод количества зарегистрированных пользователей за сутки, неделю, месяц (теги для шаблона stats.tpl {user_day}, {user_week}, {user_month} соответственно).
q Добавлено кеширование модуля общей статистики сайта.
q Добавлена автоматическая авторизация пользователей, после регистрации на сайте. Теперь после регистрации вашим посетителям не нужно вводить логин или пароль для входа на сайт, они будут автоматически распознаны скриптом.
q Добавлена возможность автоматического создания бекапа вашей базы данных. Для функционирования данной возможности, необходима поддержка вашим хостером запуска приложений по CRON, это позволяет избежать нагрузки на сервер скриптом, а также вы можете самостояльно указать, когда создавать бекап базы данных и с какой периодичностью. Также вы можете указать количество одновременно хранимых на сервере резервных копий. Более старые копии БД будут автоматически удалятся.
q Изменен принцип работы профиля пользователя. Теперь при просмотре профиля, в нем будут выводится только новости ожидающие модерации, и эти новости будут доступны для просмотра только их авторам и администраторам, для других пользователей, новости в профиле показыватся не будут. Но в данный шаблон добавлен тег {news} который выводит ссылку на просмотр всех опубликованных новостей данного пользователя. При переходе по данной ссылке будут показаны все новости пользователя, но уже без его профиля. Ссылка на просмотр всех новостей пользователя, опубликованных на сайте выглядит как http://site.ru/user/имя пользователя/news/
q При нажатии ник автора новости добавлено удобное высплывающие меню, позволяющее перейти в его профиль, найти все его публикации, отправить персональное сообщение, а администраторы могут отредактировать его профиль.
q Добавлена возможность указания в настройках скрипта краткого названия сайта, которое будет отображатся в модуле speedbar, вместо вашего основного названия сайта.
q Изменен показ списка загруженных файлов в админпанели, если раньше после загрузки в списке показывалось количество скачиваний, то сейчас показывается размер файла. Иначе многие считали что 0 это размер и загрузка файла произошла со сбоем.
q Добавлена возможность назначения собственного полностью отдельного от остальных шаблона для статических страниц.
q Переработаны алгоритмы работы с RSS потоками, добавлена совместимость с последними версиями PHP 5.2.4 и выше (тем самым решена проблема возникновения ошибки: "XML error: not well-formed (invalid token)" на нормальных рабочих RSS потоках).
q Переработан метод формирования ссылки на полную новость при включенном ЧПУ. Новый вид ссылки http://site.ru/категория/подкатегория/id-название новости.html Если новость не содержит категории то ссылка имеет вид http://site.ru/id-название новости.html. Благодаря новому формированию ссылки существенно снижается нагрузка на MySQL сервер, а также достигается лучшая поисковая оптимизация, т.к. при смене даты новости ее URL остается неизменным. Внимание новые ссылки формируются только для новых добавленных на сайт новостей, для старых новостей формируется старый вид ссылки, до тех пор пока вы неизмените дату у новости, тем самым полностью сохраняется поисковая оптимизация. Для примера вы можете посмотреть URL для данной новости на сайте http://dle-news.ru/ и URL более старых новостей.
q Добавлена поддержка скриптом PHP версий 6.xx
q Исправлена ошибка при которой происходила аварийная остановка загрузки файлов, если загружаемые файлы имели одинаковые имена.
q Существенно сокращен траффик между БД MySQL и сервером, вследствии чего снижено потребление оперативной памяти и а также увеличена скорость работы скрипта.
q Исправлены все обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 6.2:

q Оптимизирована и снижена нагрузка на MySQL сервер, генерируемая календарем. Для работы календаря были использованы более упрощенные запросы, требущие меньших затрат MySQL сервера.
q Добавлена возможность отключения поддержки мультикатегорий. За этим небольшим пунктом скрывается огромная работа по оптимизации скрипта. Мы рекомендуем всем сайтам, которые не публикуют новости в несколько категорий отключить эту поддержку в настройках скрипта, тем самым DataLife Engine будет использовать упрощенные запросы к MySQL серверу, что позволяет снизить нагрузку на MySQL до 70%, а в некоторых случаях на больших базах данных еще больше.
q Добавлена возможность во время установки скрипта указать кодировку для соединения с MySQL, в дальнейшем скрипт будет всегда использовать данную кодировку, и нет необходимости править скрипт для корректной работы скрипта, на языке, отличном от русского.
q Добавлена возможность удаления всех комментариев пользователя при редактировании его профиля, тем самым, если вы хотите например непосредственно с сайта забанить пользователя, который практикует флуд в комментариях, то вы можете также удалить и все его комментарии одним кликом.
q Полностью переработаты функции модуля "Фильтр слов", теперь данный модуль предназначен не только для удаления нежелательных слов из комментариев, но и представляет из себя модуль автопарсинга новостей и комментариев. Данный модуль теперь позволяет заменять слово или предложение на другую комбинацию слов, как в новостях, так и в комментариях. Вы можете использовать для замены как HTML, так и BB коды. Например вы можете задать так, чтобы например слово Blizzard автоматически заменялось ссылкой на сайт компании Blizzard, и т.д.
q В параметры новостей во вкладке "Дополнительно", добавлен новый параметр: "Символьный код", который позволяет группировать и выводить новости по определенному буквенному коду, тем самым добавлена возможность быстрого и удобноного способа публикации каталогов. Например вы добавляете как идентификатор букву "а" и теперь по адресу http://site.ru/catalog/a/ вы можете увидеть все новости или статьи у которых установлен символьный код "а". Допускается использовать в символьном коде до трех букв, например "abc". Если символьный код не был назначен новости, то автоматически будет назначен первый символ заголовка. Надеемся данная опция будет вам очень полезна для публикации каталогов, например видеофильмов, да и вообще чего угодно.
q Переработана панель навигации, предназначенная для перехода по страницам, при редактировании новостей в админпанели. Новая панель является более удобной при большом количестве новостей в базе данных, и занимает гораздо меньше места.
q В админпанель добавлена новая функция "Блокнот". Каждый пользователь кто имеет доступ в админпанель скрипта, может оставлять собственные памятки или заметки. Никто другой кроме автора не имеет доступа к этому блокноту, тем самым вы можете всегда иметь под рукой какую либо краткую информацию.
q Исправлены ошибка в AJAX, приводящая к некорректной проверки логинов при регистрации содержащих символ "["
q В шаблон userinfo.tpl добавлена группа тегов [time_limit] {time_limit} [/time_limit]. Данные теги выводят информацию до какого времени пользователь будет пребывать в определенной группе, при условии он находится во временно назначенной группе. Данная информация будет показыватся только самому пользователю или администраторской группе. Другим посетителям данная информация будет недоступна.
q Улучшен модуль RSS импорта новостей в админпанели. Добавлено сохранение даты последнего добавления новостей с определенного потока и при повторном получении новостей с этого потока, будут отображатся только новые новости, появившиеся только после последнего добавления.
q В RSS импорт новостей добавлена возможность быстрого удаления полученной новости из списка, не заходя при этом в саму новость.
q В шаблон main.tpl добавлена поддержка тега [not-aviable=раздел] текст [/not-aviable]. Данный тег является полной противоположностью тега [aviable=раздел] текст [/aviable] и если тег aviable предназначен для показа текста только в перечисленных разделах, то новый тег not-aviable предназначен для показа текста везде кроме перечисленных разделов. Введение данного тега, позволит вам существенно упростить создание сложного шаблона с показом нужных блоков в разделах.
q В шаблоны main.tpl, shortstory.tpl, fullstory.tpl добавлена поддержка тега [not-group=группа] текст [/not-group]. Данный тег является полной противоположностью тега [group=группа] текст [/group] и если тег group предназначен для показа текста только для перечисленных групп пользователей, то новый тег not-group предназначен для показа текста для всех кроме перечисленных групп. Введение данного тега, позволит вам существенно упростить создание сложного шаблона с показом нужных блоков для определенных групп пользователей.
q В шаблоны main.tpl, shortstory.tpl, fullstory.tpl добавлена поддержка тега [not-category=категория] текст [/not-category]. Данный тег является полной противоположностью тега [category=категория] текст [/category] и если тег category предназначен для показа текста только в перечисленных категориях, то новый тег not-category предназначен для показа текста везде, кроме перечисленных категорий. Введение данного тега, позволит вам существенно упростить создание сложного шаблона с показом нужных блоков для определенных категорий.
q В настройки групп добавлена возможность разрешения или запрещения просмотра отключенного сайта для определенной группы.
q Исправлены проблемы в модуле отображения архива новостей, при которых в данном модуле считались неопубликованные новости и новости опубликованные на будущее время.
q Добавлена возможность для BB редактора добавлять собственное описание alt для картинок и уменьшенных изображений.
q Добавлена возможность быстрого редактирования новостей при помощи AJAX на страницах поиска по сайту.
q В модуль Google Sitemap добавлена возможность устанавливать количество новостей, которые будут добавлены в карту сайта, а также приоритет этих страниц.
q Добавлена панель BB кодов в быстрое редактирование новостей и комментариев с использованием технологии AJAX, что делает быстрое редактирование еще более удобным и быстрым.
q Исправлена проблема в модуле популярных новостей при одновременном включении навигации AJAX и WYSIWYG редакторе, которая приводила к неотображению этого редактора.
q Добавлено автоматическое удаление из шаблона тегов для неиспользуемых или отключенных рекламных материалов.
q Исправлены все обнаруженные и заявленные ранее небольшие ошибки в скрипте.

Список изменений относительно версии 6.0:

q Добавлен новый WYSIWYG редактор, вернее будет сказать что существенно переработан старый WYSIWYG редактор.
q В модуль "IP утилиты" была добавлена возможность поиска по логину всех IP адресов которые использовал данный пользователь при написании комментариев
q Добавлена самая наверно ожидаемая многими функция: Все загружаемые через скрипт картинки распределяются по папкам месяцам, что позволяет держать большое количество картинок в более отсортированном виде.
q В модуль управления рекламой добавлена возможность задания для какой группы пользователей или нескольких групп показывать данную рекламу, а для каких групп отключать ее. Данное нововведение позволит вам снижать уровень рекламы для определенных групп, например для зарегистрированных пользователей.
q В модуле отправки персональных сообщений добавлена возможность использования кода безопасности (CAPTHA) при отправке персонального сообщения, тем самым блокируется вредоносное поведение отдельных пользователей на сайте. Включение данного кода производится для каждой группы отдельно, в настройках групп пользователей.
q Некоторые администраторы сайтов по непонятным причинам иногда в настройках категорий при редактировании, почему то пытаются вложить категорию саму в себя или вложить ее в собственную подкатегорию, какой логикой они пользуются при этом непонятно, но тем не менее в настройки категорий были добавлены механизмы блокирующие данное неразумное поведение с целью исключить неккорректную работу скрипта в дальнейшем.
q В модуле добавления новостей с сайта добавлена возможность использования кода безопасности (CAPTHA) при добавлении новостей. Что позволяет блокировать использования ботов автопостинга новостей на вашем сайте. Включение или отключение кода безопасности производится в админпанели в настройках скрипта, в разделе настройки новостей.
q Добавлен новый модуль Google Sitemap. Создание карты сайта для поисковой системы Google производится одним нажатием кнопки, в любое необходимое время, карта хранится на сервере уже в созданом виде, поэтому не создает нагрузки на сервер.
q Максимальная длина URL новых новостей сокращена до 40 символов при формировании ЧПУ, тем самым снижена нагрузка на MySQL сервер при просмотре данных новостей, где используется длинный заголовок и автоматическое формирование URL новости
q Исправлена ошибка в модуле поиска по сайту, при которой в поиске участвовали также новости, дата публикации которых еще не наступила.
q Добавлена возможность в настройках групп разрешать или запрещать участвовать той или иной группе в выставлении рейтинга для новостей.
q Улучшен модуль вывода похожих новостей. В эвристический анализ добавлен заголовок новости и дополнительные поля новости.
q Исправлена ошибка в модуле "поиска и замены" в админпанели, которая приводила к потере дополнительных полей.
q Улучшено совместное использование различных типов редакторов одновременно. Например если ваши посетители добавляют новости, используя BBCODES редактор, а вы редактируете новость, используя WYSIWYG редактор. При этом исключено попадание и неккоректное в дальнейшем использование служебных кодов от BB редактора, которые используются для переконвертирования.
q Исправлены проблемы в модуле RSS информеров, приводящие в определенных случаях к неверному подсчету максимального количества выводимых символов.
q Исправлены небольшие недочеты в автоматическом формировании метатегов.
q Добавлена автоматическая поддержка ссылок типа: mms:// при использовании BBCODES редактора
q Добавлено использования двух механизмов для поиска. Простой поиск и полнотекстовый. Полнотекстовый поиск полностью задействует индексы MySQL и ведет более более качественный поиск по поисковым словам, используя различные комбинации. Простой поиск ведет поиск менее качественно, но иногда может потреблять менее ресурсов. Также был полностью переработан полнотекстовый поиск по сравнению с версией 6.0, существенно увеличена скорость работы и используются менее сложные запросы. Также добавлена поддержка MySQL 3.xx тем самым снижены минимальные системые требования для работы со скриптом.
q Улучшен механизм формирования ссылок ЧПУ для новостей, слова в URL теперь разделяются через дефис, также исключено повторение разделяющих слова дефисов, другими словами ссылка на новость, стала иметь более приятный вид.
q В настройки скрипта добавлена возможность включать или выключать возможность выставления рейтинга за новость при просмотре кратких новостей. Если эту возможность отключить, то за новость можно проголосовать только при просмотре полной новости.
q Изменена логика применения настроек скрипта при загрузке изображений на сервер. Если установлено ограничение на размер сторон оригинального изображения, то проверка ограничения на вес изображения не производится, все равно данная картинка будет автоматически уменьшена до нужных размеров и соответственно ее вес будет гораздо меньше.
q Добавлен код безопасности в модуль восстановления забытого пароля, с целью исключить массовый почтовый спам на нежелательного пользователя
q Добавлено автоматическое удаление тега RSS информера из шаблона если данный информер не должен показываться согласно его настройкам в админпанели.
q Улучшена система распознования и реагирования на неожиданные ошибки в RSS потоках в модулях "RSS импорт" и "RSS информеры", данные ошибки корректно обрабатываются скриптом и не вызывают его неожиданной остановки.
q Внесено множество небольший улучшений и оптимизаций в код скрипта, а также исправлены все обнаруженные и заявленные ранее ошибки скрипта.


Установка и обновление скрипта

Установка скрипта на сервер

Установка скрипта на сервер проходит в автоматическом режиме и не должная вызывать особых проблем, но вам необходимо выполнить некоторые действия по настройке прав доступа на папки.

1. Для начала скопируйте все файлы из папки upload в данном архиве на ваш сервер.
2. Установите для папки templates и всем вложенным в нее папкам права на запись (CHMOD 777)
3. Установите для всех файлов в папке templates права на запись (CHMOD 666)
4. Установите права для записи (CHMOD 777) для папок backup, uploads, а также для всех папок, находящихся внутри них.
5. Установите права для записи (CHMOD 777) для папок /engine/data/, /engine/cache/, /engine/cache/system/.
6. Запустите файл install.php и следуйте его инструкциям.

Автоматический инсталлятор проверит все необходимые файлы и настроит подключение к базе данных. После завершения установки вы сможете посмотреть работу скрипта на демонстрационной странице http://website.com/index.php. Для доступа к админпанели необходимо запустить http://website.com/admin.php

Обновление скрипта с более старых версий:

1. Создайте резервную копию базы данных и всех файлов скрипта на сервере.
2. Обновите все файлы из папки /upload/ вашего архива (за исключением /templates/). Внимание: Файлы из архива дистрибутива, нужно заливать на сервер поверх существующих, а не удалять предварительно папки на сервере.
3. Запустите файл http://website.com/upgrade/index.php, и следуйте дальнейшим инструкциям.
4. Удалите папку /upgrade/ и файл install.php с вашего сервера.
5. если в вашей папке /templates/ отсутствует папка с шаблоном smartphone, то скопируйте ее из архива дистрибутива.
6. В админпанели на главной странице выберите "Очистку кеша"
7. Внесите необходимые изменения в ваши шаблоны, согласно списку изменений, опубликованному на сайте вместе со ссылкой на дистрибутив.
8. Проверьте настройки скрипта в админпанели.

Внимание: обновление скрипта возможно только с версий 3.5 и выше, поддержка более ранних версий прекращена.


Начало работы и шаблоны

Одной из особенностей движка является то, что в него можно подключить любой существующий дизайн не испытывая при этом каких-либо ограничений. Движок поддерживает работу с несколькими шаблонами одновременно. Все шаблоны находятся в папке /tеmplates/. Каждая вложенная папка в этой папке является отдельным макетом сайта. Поэтому если вы скачали новый скин для движка просто скопируйте его в папку и разрешите его использование в админ панели. Также мы можете разрешить смену дизайна для посетителей вашего сайта и они сами смогут выбрать, как будет выглядеть их любимый сайт. Также вы можете установить количество новостей, выводимых на страницу, для этого зайдите в настройки скрипта и установите соответствующий параметр.

Внимание: В файлах шаблона вы можете использовать обычный html текст, либо можете использовать специальные теги, для вставки тех или иных возможностей, прочитать подробнее о допустимых тегах вы сможете в данном руководстве ниже в разделе Шаблоны.


Вывод новостей на страницах

Основной макет вашей страницы находится в файле шаблона main.tpl именно этот файл движок подгружает в первую очередь и к нему подключаются все другие компоненты движка. Остановимся на основных из них. {AJAX}, {info}, {content}, {custom} именно эти теги отвечают за правильный вывод новостей.

Тег {AJAX} выводит служебные скрипты JavaScript необходимые для нормальной работы движка в целом и технологии AJAX в частности. Рекомендуется размещать в самом начале шаблона после тега <body>

Тег {info} выводит служебную информацию и ошибках о произведенных действиях (например "Вход не выполнен, неверный пароль" или "Необходимо заполнить все поля") рекомендуется устанавливать перед тегом {content}

Тег {content}, отвечает за непосредственный вывод статей и прочих встроенных модулей в движок

Тег {tags}, отвечает за вывод облака тегов (специальных ключевых слов добавленнных в новость)

Теги [sort]{sort}[/sort], отвечают за вывод выбора пользователем порядка сортировки новостей, если это разрешено в настройках скрипта

Тег {custom}, отвечает за вывод статей в пользовательском формате, имеет следующие параметры:

{custom category="2,7" template="custom" aviable="global" from="0" limit="10" cache="yes"}

Где

category это список ID категорий, из которых производить выборку новостей, разделяются запятой без пробелов.

template файл шаблона который будет использоваться при выводе новостей в данном случае это будет custom.tpl если вы используете на сайте несколько шаблонов то данный файл должен присутствовать в каждом шаблоне. В данном шаблоне используются теги аналогичные для короткой новости.

aviable раздел в котором будет выводится запрашиваемые новости, может принимать следующие значения:

global - во всех разделах

main - на главной странице

date - при просмотре новостей за определенные даты

cat - при просмотре категории

showfull - при просмотре полной новости

search - при просмотре результатов поиска

userinfo - при просмотре профиля

register - при регистрации

stats - при просмотре статистики

pm - при просмотре персональных сообщений

feedback - при просмотре обратной связи

favorites - при просмотре закладок

newposts - при просмотре новых сообщений

addnews - при добавлении новости

lastcomments - при просмотре последних комментариев

static - при просмотре статических страниц

catalog - при просмотре каталога страниц

alltags - при просмотре облака тегов

tags - при просмотре новостей из облака тегов

Вы можете комбинировать разделы при помощи "|", например aviable="userinfo|register|main" будет выводить ваши новости на главной, при регистрации и при просмотре профиля пользователя.

from номер новости с которой начнется вывод

limit сколько новостей будет выведено

cache принимает значения yes или no - устанавливает кешировать вывод или нет, рекомендуется кешировать для снижения нагрузки.

Внимание необходимо указывать все параметры обязательны а также необходимо соблюдать их порядок.

Помните что каждое использование этого тега создает дополнительную нагрузку на базу данных, т.к. идет дополнительная выборка, поэтому используйте ее с умом если необходимо экономить на ресурсах.

Тег [aviable=раздел]текст[/aviable], выводит текст заключенный в теги если просматривается указанный раздел сайта:

Тег принимает параметры аналогичные параметру aviable тега {custom}.

Для примера

[aviable=userinfo|register|main] текст [/aviable]

будет выводить текст заключенный в теги, на главной, при регистрации и при просмотре профиля пользователя.

Внимание вы можете задать также тег [not-aviable=userinfo|register|main] текст [/not-aviable] который полностью противоположен тегу aviable и выводить текст везде кроме перечисленных разделов.

Тег [category=X]текст[/category], выводит текст заключенный в теги если просматривается указанная категория:

Тег принимает в качестве параметра ID категории, и допускает перечисление нескольких категорий

[category=1,2,3] текст [/category]

будет выводить текст заключенный в теги, если посетитель просматривает категории у которых ID равен 1 или 2 или 3.

Внимание вы можете задать также тег [not-category=1,2,3] текст [/not-category] который полностью противоположен тегу category и выводить текст везде кроме перечисленных категорий.

Тег [group=X]текст[/group], выводит текст заключенный в теги если пользователь принадлежит указанной группе пользователей:

Тег принимаем в качестве параметра ID группы, и допускает перечисление нескольких групп

[group=1,2,3] текст [/group]

будет выводить текст заключенный в теги, если посетитель является администратором, главным редактором или журналистом.

Внимание вы можете задать также тег [not-group=1,2,3] текст [/not-group] который полностью противоположен тегу group и выводить текст для всех, кроме перечисленных групп.

{banner_имя} этот тег предназначен для вывода рекламной информации на сайте. Само имя для баннера задается в специальном модуле в админпанели.

{inform_имя} этот тег предназначен для вывода RSS информеров и новостей с других сайтов. Имя и все настройки для данного тега устанавливаются в админпанели скрипта.

[static=имя страницы] текст [/static]

будет выводить текст заключенный в теги, если посетитель просматривает статическую страницу с указанным именем.

[not-static=имя страницы] текст [/not-static]

будет выводить текст заключенный в теги, если посетитель не просматривает статическую страницу с указанным именем.

Также вы можете подключать один шаблон в другой, используя тег {include file="my_block.tpl"} данный тег подключает указанный файл my_block.tpl в шаблон. Тег призван облегчить структуру шаблона, если используется сложная верстка со множеством тегов.


Теги при написании новостей

При написании новостей допустимо использование следующих тегов, если вы не используете WYSIWYG редактор:

[b] текст [/b] Выделяет текст жирным шрифтом

[i] текст [/i] Выделяет текст наклонным шрифтом

[s] текст [/s] Зачеркивает текст

[u] текст [/u] Подчеркивает текст

[code] текст [/code] отменяет использование форматирования текста заключенного в теги

[left] текст [/left] Выравнивает текст по левому краю

[center] текст [/center] Выравнивает текст по центру

[right] текст [/right] Выравнивает текст по правому краю

[url=ссылка] текст [/url] Вставка ссылки в новость

[leech=ссылка] текст [/leech] Полностью аналогичен тегу URL, за исключением того что производит шифрование ссылки

[email=ссылка] текст [/email] Вставка e-mail адреса в новость

[img] ссылка [/img] Вставка картинки новость

[img=выравнивание] ссылка [/img] Вставка картинки новость и выравнивание ее по указанному параметру

[img=выравнивание|свой текст для alt] ссылка [/img] Вставка картинки новость и выравнивание ее по указанному параметру, а также назначение картинке собственного описания

[color=цвет] текст [/color] Изменение цвета текста на указанный

[quote] текст [/quote] Цитата

[hide] текст [/hide] Скрывает текст от не зарегистрированного посетителя

{pagebreak} Разрыв страницы

[page=номер страницы] текст [/page] Вставка ссылки на указанный номер страницы внутри новости

[thumb] ссылка [/thumb] Вставка уменьшенной копии картинки новость, с ссылкой на увеличенную картинку

[thumb=выравнивание] ссылка [/thumb] Вставка уменьшенной копии картинки новость, с ссылкой на увеличенную картинку и выравнивание ее по указанному параметру

[thumb=выравнивание|свой текст для alt] ссылка [/thumb] Вставка уменьшенной копии картинки новость, с ссылкой на увеличенную картинку и выравнивание ее по указанному параметру, а также назначение картинке собственного описания

[video=http://test.ru/video.avi] Позволяет установит проигрывание видеофайла в новости

[video=http://test.ru/video.avi|http://test.ru/sample.jpg] Позволяет установит проигрывание видеофайла в новости, а также картинку предосмотра для перед началом проигрывания.

[audio=http://test.ru/music.mp3] Позволяет установит проигрывание MP3 в новости

[font=имя шрифта] текст [/font] Написание текста определенным шрифтом

[size=размер] текст [/size] Написание текста определенным размером шрифта

[spоiler] текст [/spoiler] Скрывает указанный в теге текст и показывает его при клике на него

[spоiler=Заголовок] текст [/spoiler] Выводит собственный заголовок по щелчку на который будет показан скрытый текст

[youtubе=ссылка на страницу с видео] предназначен для публикации видео на сайте с таких видеохранилищ как youtube.com и rutube.ru. В данном теге вы просто указываете URL страницы видеохранилища где размещено видео, скрипт автоматически распознает тип видеохранилища и вставит нужный HTML код для просмотра видео.

[flash=ширина,высота] Путь к ролику [/flash] предназначенный для вставки флеш роликов в формате swf.

Небольшие пояснения к вставке кодов:

Например если вы хотите вставить картинку в текст то используйте тег [img]http://website/image.jpg[/img], если хотите ее выровнять по левому или по правому краю то используйте [img=left]http://website/image.jpg[/img], если же картинку нужно выровнять по центру то используйте следующее написание [center][img]http://website/image.jpg[/img][/center]. Аналогичный принцип действует и для тега [thumb]. Например, ваша статья содержит несколько страниц, и вы хотите на какой-либо странице помимо стандартной навигации между ними, зашитой в шаблоне, использовать свою ссылку на какую-либо страницу, то вставьте следующий код [page=3] для просмотра 3 страницы жми тут[/page] где 3 это номер страницы вашей новости.


Избранное / Фавориты

Возможности движка позволяют каждому зарегистрированному пользователю добавлять понравившуюся новость в свои закладки. Не путайте с закладками браузера. После авторизации на сайте каждый посетитель может добавить новость в закладки нажав на плюсик, после этого он может легко просмотреть новость или комментарии к ней, независимо от даты новости и не используя при этом поиск.


Персональные сообщения

Все авторизованные на сайте пользователи могут отправлять друг другу персональные сообщения. Данные сообщения в дальнейшем можно просматривать, удалять их, а также отвечать на них. Для этого используется определенный шаблон для их вывода. При редактировании этого шаблона будьте предельно внимательны. Чтобы не нарушить функциональность этого модуля. Для редактирования этого шаблона не требуется знание PHP, однако вы должны разбираться в HTML и его особенностях. Другими словами просто не изменяйте без особой надобности поля для ввода информации из форм.


ЧПУ и настройка

DataLife Engine использует в своей работе для вывода новостей ЧПУ (человеко-понятный URL), что позволяет тему статьи или любой другой текст добавить в URL браузера, благодаря этому индексация сайта в поисковых системах будет более качественной, что приведет больше посетителей на ваш сайт с поисковых систем. Для работы ЧПУ необходимо чтобы на вашем сервере был установлен модуль modrewrite. Если Ваш сервер не поддерживает этого, то вы можете отключить эту функцию. Для этого вам необходимо обязательно удалить с корневого каталога файл .htaccess и при установке скрипта отключить поддержку этой функции. Для более корректной работы ЧПУ мы рекомендуем устанавливать скрипт в корневую папку вашего сайта.

При включенном ЧПУ ссылки будут имеют следующий вид

Полная новость

С использованием ЧПУ зависит от типа ЧПУ установленного в настройках скрипта

http://website.com/index.php?newsid=1234543 - без использования ЧПУ

Добавление новостей на сайт вашими посетителями

http://website.com/addnews.html - с использованием ЧПУ

http://website.com/index.php?do=addnews - без использования ЧПУ

Профиль пользователя

http://website.com/user/имя пользователя/ - с использованием ЧПУ

http://website.com/index.php?subaction=userinfo&user= имя - без использования ЧПУ

Регистрация на сайте

http://website.com/index.php?do=register - без использования ЧПУ

Обзор непрочитанных сообщений

http://website.com/newposts/ - с использованием ЧПУ

http://website.com/index.php?subaction=newposts - без использования ЧПУ

Вывод всех новостей

http://website.com/lastnews/ - с использованием ЧПУ

http://website.com/index.php?do=lastnews - без использованиия ЧПУ

Вывод всех новостей указанной категории

http://website.com/альтернативное имя категории/ - с использованием ЧПУ

http://website.com/index.php?do=cat&category=альтернативное имя - без использования ЧПУ

Вывод всех новостей за 2005 год

http://website.com/2005/ - с использованием ЧПУ

http://website.com/index.php?year=2005 - без использованиия ЧПУ

Вывод всех новостей за указанный месяц

http://website.com/2005/12/ - с использованием ЧПУ

http://website.com/index.php?year=2005&month=04 - без использования ЧПУ

Вывод всех новостей за указанный день

http://website.com/2005/12/01/ - с использованием ЧПУ

http://website.com/ index.php?year=2005&month=04&day=30 - без использования ЧПУ

Обратная связь с администрацией сайта и другими участниками

http://website.com/index.php?do=feedback

Каталог сайта (сортировка по символьному коду)

http://website.com/catalog/a/ - с использованием ЧПУ

http://website.com/index.php?catalog=а - без использованиия ЧПУ

Вывод облака тегов

http://website.com/tags/ - с использованием ЧПУ

http://website.com/index.php?do=tags - без использованиия ЧПУ

Правила сайта

http://website.com/rules.html - с использованием ЧПУ

http://website.com/index.php?do=rules - без использованиия ЧПУ

Ссылки для вывода всех новостей указанной категории вы должны самостоятельно добавить в дизайн вашей страницы. Более подробно о создании категорий читайте ниже.


Поддержка Смартфонов

Datalife Engine позволяет автоматически определять с использованием чего посетитель заходит на ваш сайт. И в случае если пользователь заходит на ваш сайт с мобильного аппарата, то DataLife Engine способен распознать это и подготовить для вывода специальную облегченную версию вашего сайта, с минимумом графики и использованного для передачи трафика.

Для включения данной возможности вам необходимо в Админпанели в настройках скрипта включить пункт: Включить автоматическую поддержку смартфонов, там же в настройках скрипта вы можете включить вывод в новостях картинок или отключить. Также можно принудительно включить отображение версии сайта для смартфонов, для этого нужно перейти по ссылке http://site.ru/index.php?action=mobile

Также в вашей папке шаблонов /templates/ должна находится папка с шаблоном smartphone именно этот шаблон используется для вывода сайта в случае если пользователь зашел на ваш сайт с использованием мобильного телефона. В данном шаблоне вы можете использовать все теже возможности что и в обычном шаблоне. Все теги и возможности полностью идентичны обычному шаблону. Но мы рекомендуем использовать самый минимум и не забывать о размерах экрана мобильного телефона. В архиве дистрибутива мы подготовили один такой стандартный шаблон с самым минимумом информации и размером. На него мы и рекомендуем опираться, при создании собственного шаблона.


Добавление новостей

Вход в админцентр осуществляется по адресу http://website.com/admin.php После авторизации вы сможете добавлять, редактировать и удалять новость, управлять пользователями и шаблонами, производить настройку скрипта, управлять картинками и многое другое.

При добавлении новости на сайт Вам необходимо задать заголовок статьи. Поле ЧПУ URL статьи является необязательным используется при включенных ЧПУ. Вы можете задать там свой текст, который будет в строке браузера, либо можете оставить его пустым, тогда текст будет сформирован из заголовка статьи, с учетом правил транслитации. Поле Дата задает дату новости, если отмечена галочка Текущая дата то будет автоматически вставлена текущая дата, с учетом коррекции времени, либо вы можете снять эту галочку, и ввести дату самостоятельно используя удобный календарь, нажав на значок рядом с полем. Если указать дату которая не наступила, то новость будет автоматически опубликована при наступлении указанной даты, при условии что новость допущена к публикации. Также вы можете выбрать категорию к которой принадлежит статья. После этого используя удобные кнопки для вставки тегов напишите вашу новость в кратком и полном описании, также если созданы дополнительные поля введите информацию и там. Внимание поле Полная описание не является обязательным если оно пустое, то текст будет автоматически взят с Краткого описания. Используя ссылку [Загрузить картинку] вы сможете вставить в текст новости загруженные на сервер картинки либо загрузить непосредственно для этой статьи свою картинку. Также имеется возможность загрузки картинки непосредственно с другого сервера, минуя загрузку на собственный компьютер. Внимание если вы загружаете для этой статьи собственные картинки, то они будут автоматически удалены с сервера, при удалении новости.


Редактирование новостей

Редактирование новостей идентично их добавлению за исключением поля Дата. Вы можете либо не изменять дату, для этого оставьте отмеченным Не изменять дату новости, либо снимите с него флажок и установите на Текущая дата и время, либо введите свою дату используя календарь.


Личные настройки

В данном разделе вы сможете редактировать свой собственный профиль, изменить E-mail адрес, поменять дополнительные поля в виде полного имени, места жительства, номера ICQ, установить новый пароль.


Настройка системы

В данной разделе осуществляется общая настройка параметров системы, обратите внимание на то что настройка разбиты на разделы и для выбора раздела просто нажмите на соответствующую иконку. Пожалуй стоит остановиться на каждом пункте подробнее:

Название сайта – Введите название вашего сайта, например «Моя домашняя страница»

Домашняя страница сайта – Введите URL к главной странице, без указания имени файла, например http://website.com/ Обратите внимание на то что слеш на конце обязателен.

E-Mail адрес администратора – Адрес с которого будут отсылаться все письма с сервера для посетителей

Шаблон сайта по умолчанию – Выберите скин, который будет использоваться при отображении вашего сайта по умолчанию

Используемый язык – Выберите язык по умолчанию, который будет использоваться для вывода всех сообщений скрипта

Количество новостей на страницу – Укажите сколько новостей будет показываться при просмотре кратких статей

Включить WYSIWYG редактор при добавлении новостей с сайта - При добавлении новостей посетителями непосредственно с сайта возможно либо с использованием WYSIWYG редактора либо с использованием BBCODES Обратите внимание на то чтобы ваш шаблон был соответственно настроен

Включить WYSIWYG редактор в админпанели - Включает данный редактор в админпанели

Включить WYSIWYG редактор для комментариев и персональных сообщений - При добавлении комментариев посетителями непосредственно с сайта возможно либо с использованием WYSIWYG редактора либо с использованием BBCODES Обратите внимание на то чтобы ваш шаблон был соответственно настроен

Автоматическая разбивка длинных слов – Введите максимальное количество символов в одном слове, при превышение этого значение длинное слово будет автоматически переноситься на новую строчку, данная функция необходима чтобы длинные слова не

испортили общий дизайн сайта

Защита от флуда – Количество секунд в течении которых будет запрещено повторное написание комментария

Смайлики – Перечислите через запятую названия файлов со смайликами, которые будут использоваться при добавлении новостей или комментариев

Коррекция временных зон – Указывается в минутах, необходимо для синхронизации времени сервера со временем с учетом вашего часового пояса, допускаются также и отрицательные значения, если ваше время меньше времени сервера

Автоматическое уменьшение загруженной картинки – Указывается максимальная длина одной из сторон загружаемой картинки, если какая либо сторона по горизонтали или по вертикали превышает указанное значение, то картинка будет уменьшена до этого значения с сохранением пропорций.

Формат времени для новостей – указывается формат в котором будет выводится дата публикации новости

Включить gzip сжатие – Включает передачу контекста в сжатом виде, экономя при этом трафик

Скрывать ссылку на полую новость – скрывает ссылку на полную новость, если новость при этом отсутствует

Комментарии для зарегистрированных – Если установлено «Да» то комментарии смогут добавлять только зарегистрированные на сайте посетители

Разрешить редактирование комментариев – Если установлено «Да» то посетители смогут редактировать свои собственные комментарии, администратор может редактировать комментарии всегда

Разрешить удаление комментариев - Если установлено «Да» то посетители смогут удалять свои собственные комментарии

Формат времени для комментариев - указывается формат в котором будет выводится дата публикации комментария

Включить ЧПУ - Если установлено «Да» то будет включена поддержка ЧПУ

Разрешить фиксацию новостей - Если установлено «Да» то новости при добавлении можно будет фиксировать, фиксация новостей доступна только пользователю со статусом Администратор

Включить кеширование на сайте - Если установлено «Да» то будет включено кеширование страниц, при это теряется часть динамики сайта, до тех пор пока не обновиться кеш, однако включение данного параметра рекомендуется для сайтов с большой посещаемостью.

Включить голосование на сайте - Если установлено «Да» то будет включен модуль голосований на сайте

Включить счетчик просмотров новостей - Если установлено «Да» то будет включен счетчик показывающих сколько раз была просмотрена та или иная статья на сайте

Включить календарь - Если установлено «Да» то будет включен вывод календаря на странице, отключение календаря позволяет сэкономить один запрос к базе данных

Включить вывод архивов - Если установлено «Да» то будет выводиться архив по месяцам, отключение данной функции позволяет сэкономит один запрос к базе данных

Включить поддержку регистрации на сайте - Если установлено «Да» то будет разрешена регистрация посетителей на сайте, отключение данной функции позволяет сэкономить 2 запроса к базе данных, поэтому если вы считаете что регистрация на сайте вам не нужна то просто отключите эту функцию

Способ регистрации на сайте - Возможно два варианта, простой и расширенный при включении расширенного способа будет производиться проверка введенного E-Mail адреса. Пользователь будет должен активировать свой аккаунт при получении соответствующего письма

Разрешить смену скинов посетителями сайта – Если вы установили на сайт несколько шаблонов, то ваши посетители смогут их выбирать по своему усмотрению.

Максимальное количество зарегистрированных пользователей – Максимальное количество пользователей допустимых к регистрации, если указать 0, то регистрация будет осуществляться без ограничений

Автоматическое удаление зарегистрированных пользователей – количество дней через которое будет удален пользователь если он не посещал сайт, если указать 0, то ограничений не будет

Размер фотографии – Максимальный размер любой из сторон фотографии в профиле пользователя, при превышении данного параметра фотография будет автоматически изменена до указанного размера с сохранением пропорций.

Разрешить накладывание водяного знака – Если разрешить то на все загруженные картинки будет наложен водяной знак

Минимальный размер для накладывания водяного знака – Минимальный размер любой из сторон изображения, до которого водяной знак накладываться не будет

Разрешить пользователям загружать картинки - При добавлении новостей с сайта, вы можете своим посетителям разрешить или запретить загрузку картинок на сервер.

Максимально допустимый объём изображения - Если вы разрешили своим посетителям загрузку картинок на сервер, то вы можете ограничить максимальный объем картинки

Автоматическое удаление изображений - Если посетитель загрузил картинку, но не добавил ее в новость, она будет удалена через казанное количество дней.

Качество сжатия .jpg изображения - Качество сжатия JPEG картинки при копировании на сервер


Голосования

В данном разделе вы можете создавать, редактировать и удалять опросы на сайте. Вы можете создавать опросы которые будут видны на всех страницах сайта, а также опросы которые будут видны только при просмотре определенных категорий.


Статические страницы

Помимо написания динамически изменяемых новостей движок позволяет также написание статистичесих страниц, частое изменение которых не планируется. Для того чтобы создать статическую страницу выберите "Создать новую страницу" после этого напишите название страницы, причем только латинскими буквами, потому что оно будет передаваться в URL сайта для просмотра, также введите описание страницы, это информация только для вас, и последнее создайте шаблон самой страницы, разрешено использование HTML. После создания страницы вы сможете ее просмотреть, изменить, либо удалить.

Адрес статической страницы с использование ЧПУ выглядит так: http://webseite.com/название страницы.html

Адрес статической страницы без ЧПУ выглядит так: http://webseite.com/index.php?do=static&page=название страницы


Группы пользователей

В данном разделе вы можете добавлять и редактировать новые и существующие группы пользователей. При добавлении новой группы пользователей вы выставляете ей доступные категории и права на сайте.

Доступные разделы: Разделы в которые имеет доступ выбранная группа

Доверительные разделы: В случае если разрешаете группе публиковать новости на сайте без предварительной модерации, либо разрешаете редактировать новости других пользователей, то в данном пункте вы указываете какие разделы вы доверяете группе. Редактирование новостей в неуказанных группах будет запрещено. Посетитель всегда может добавлять новости в доступные ему разделы, но если одна из категорий будет не в доверительном разделе то вся новость не будет опубликована без предварительной модерации. Категории в которые неразрешено добавлять новости без модерации выделяются красным цветом при добавлении.

Разрешить доступ в админпанель: данная опция разрешает пользователю доступ в админпанель, но не предоставляет доступа ко всем ее функциям. Разрешается доступ только для добавления или редактирования новостей из админпанели. Доступ ко всем функциям имеют только Администраторы.

Скрывать только полную новость из недоступных разделов: В случае если пользователю запрещен доступ в раздел вы можете выбрать, запретить ему полный доступ, либо запретить только просмотр полных новостей. В случае если вы запретите просмотр только полных новостей вы существенно сократите нагрузку на сервер и время выборки новостей.

Разрешить добавлять новости Вы можете запретить либо разрешить пользователям добавлять новости на сайт.

Публиковать новости без проверки: Разрешение на публикацию новостей в доверительные разделы без предварительной модерации

Разрешить фиксировать новости: Разрешение пользователям фиксировать новости на сайте

Редактирование собственных новостей: Разрешение пользователям редактировать собственные новости уже после опубликования на сайте

Редактирование всех новостей: Разрешение пользователям редактировать любые новости из доверительных разделов.

Разрешить добавление комментариев: Разрешение пользователям оставлять комментарии на сайте

Изменение своих комментариев: Разрешение пользователям редактировать собственные комментарии

Удаление своих комментариев: Разрешение пользователям удалять собственные комментарии

Изменение всех комментариев: Разрешение пользователям производить изменение любых комментариев

Удаление всех комментариев: Разрешение пользователям проводить удаление любых комментариев на сайте

Просмотр скрытого текста: Разрешение пользователям на просмотр содержимого тега [hide] [/hide]

Разрешить использование PM: Разрешение пользователям использование персональных сообщений на сайте.

Разрешить скачивание файлов: Разрешение пользователям скачивать загруженные на сервер файлы

Использование обратной связи: Разрешение пользователям использовать обратную связь на сайте

Использование поиска по сайту: Разрешение пользователям использовать поиск по сайту

Временное размещение в группе: Вы можете временно размещать пользователей в данной группе, при переносе пользователя в данную группу укажите до какого срока он будет размещен в данной группе, после окончания данного срока, пользователь будет автоматически перемещен в основную группу

Основная группа по окончании лимита: Укажите основную группу пользователя в которую он будет перемещен после окончания срока пребывания во временной группе.


Настройка категорий

В данном разделе вы можете создавать и редактировать категории. При создании новой категории вы указываете ее имя, альтернативное имя категории, путь для иконки категории, выбрать является ли новая категория подкатегорией и где. А также дополнительно вы можете указать какой шаблон будет использоваться при показе статей из данной категории, а также при просмотре этой категории. Иконка является необязательным параметром. Внимание: альтернативное имя задается только латинскими буквами и служит для вывода всех новостей данной категории. Например вы создаете категорию с именем «Софт», и альтернативным именем «soft», то для просмотра всех новостей из указанной новости при включенном ЧПУ в строке браузера необходимо набрать http://website.com/soft/, а при выключенном ЧПУ необходимо набрать http://website.com/?do=cat&category=soft


Дополнительные поля

В данном разделе вы сможете создавать и редактировать дополнительные поля. Дополнительные поля, позволяют облегчать добавление информации на сайт, по умолчанию имеются только два поля, это краткое и полное описание новости. Однако вы можете создать и другие поля для ввода информации, например ссылку на источник или на программу, и настроив вывод поля всего один раз в шаблонах, отпадает необходимость постоянного форматирования часто повторяющегося ввода информации.

При добавлении нового поля вы вводите его название (латинскими буквами), описание поля (выводится рядом с полем ввода), категорию к которой принадлежит данное поле (вы можете выбрать, вводить ли данное поле для всех категорий или данное поле принадлежать только одной категории, вы можете назначать также выборочно, категории к которым будет принадлежать данное поле, для этого в выпадающем меню выберете «Выбрать» и впишите через запятую ID номера категорий), тип поля (вы можете выбрать три типа поля, либо это одна строка, либо это какой то большой текст, либо это выпадающее меню со списком значений), также можете назначить значение поля по умолчанию. Если вы хотите чтобы поле являлось необязательным при вводе информации, поставьте соответствующую галочку, в противном случае новость не будет добавлена, если данное поле не введено.


Фильтр по IP, Логину или E-Mail

Вы можете воспользоваться данным разделом, чтобы заблокировать определенные IP адреса, или заблокировать определенные электронные адреса, имена пользователей при регистрации. При вводе IP адреса, то доступ на сайт данному IP или подсети закрывается полностью, а не только для регистрации.

Примечание: вы можете воспользоваться в фильтре символом звездочки * для подстановки в имя пользователя, IP адрес или электронный адрес (например: 127.0.*.*, *@mail.ru, username*).


IP утилиты

Данный модуль предназначен, для быстрого и удобного поиска и редактирования пользователей, использовавших для регистрации или авторизации указанный IP адрес. Допускается поиск как по полному IP адресу, так и по сокращенному. Также в данном модуле вы можете найти все IP адреса которые использовал определенный пользователь.


Управление рекламой

Данный модуль предназначен, для быстрого и удобного размещения и управления вашими рекламными материалами на сайте. Для того чтобы разместить на сайте ваш баннер, вам достаточно один раз добавить тег баннера в шаблон, после чего вы можете без проблем менять или редактировать код баннера в админпанели, не затрагивая при этом шаблоны.

После добавления своего баннера вы можете разместить его тег в шаблонах main.tpl или fullstory.tpl. Если вы добавляете баннер для показа между короткими новостями, то добавлять тег в шаблон ненужно, баннер будет добавлен между новостями автоматически.

Пример работы:

- Название: header
- Описание: Верхний баннер
- Включить показ баннера: Да
- Показывать только на главной: Нет
- Закрепить в расположении: Нет
- Расположение в коротких новостях: Нет

Если вы хотите чтобы данных баннер показывался только для определенных групп, то вы можете выбрать при добавлении баннера те группы пользователей, для которых необходимо показывать данный баннер. Также вы можете установить дополнительно время и дату начала показа баннера и время и дату окончания показа

После этого вы можете добавить в ваш шаблон в main.tpl или fullstory.tpl тег для вывода баннера: {banner_header}

Вы можете при добавлении кода баннера использовать HTML и JavaScript.


RSS информер

Данный модуль предназначен для публикации новостей ваших партнеров с других сайтов в определенном блоке на вашем сайте. Зайдя в админпанель для добавления нового информера вы задаете ему следующие параметры:

Название RSS информера - в данном поле вы указываете имя для информера имя может быть уникальным а может быть таким же как и у других информеров. В случае если имя одинаковое то информеры показываются в режиме ротации.

Описание RSS информера - краткое описание предназначенное для вас этого информера

Категория - вы можете указать категорию в которой показывать этот информер, либо сделат доступным показ во всех категориях

URL для RSS информера - здесь вы указываете путь к RSS источнику из которого будут братся новости

Шаблон для информера - укажите шаблон который будет подгружатся для показа отформатированной информации в этом блоке. Например informer.tpl

Количество новостей в блоке - укажите количество новостей которые должны показываться в данном блоке

Количество символов в заголовке - укажите максимальное количество символов в заголовке, при превышении данного лимита заголовок будет автоматически обрезаться. Вы можете установить значение 0, тогда заголовок будет импортироватся целиком

Количество символов в тексте новости- укажите максимальное количество символов в новости, при превышении данного лимита новость будет автоматически обрезаться. Вы можете установить значение 0, тогда новость будет импортироватся целиком


Используемые классы CSS

DataLife Engine использует следующие классы CSS:

.calendar - Вывод таблицы календаря

.monthlink - Ссылка перехода по месяцам в календаре

.weekday - Субботний и воскресный дни

.weekday-active - Субботний и воскресный дни если посетитель просматривает этот день

.day-active - Неактивные субботние и воскресные дни

.weekday-active-v - Активный рабочий день

.day-active-v - Неактивный рабочий день

.day - Если новостей в этот день нет

.day-current - Текущая дата

.archives - Вывод списка архивов

.sresult - Вывод количества найденный новостей при поиске

.xfields - Ввод дополнительный полей в добавлении новости

.rating - Вывод рейтинга

.quote - Используется для вывода цитаты или информации о скрытом тексте

.scriptcode - Используется для вывода информации, заключенной в тег [CODE]

.pm - Таблица при выводе списка полученных приватных сообщений

.pm_head - Заголовок таблицы

.pm_list - Список самих сообщений

#dropmenudiv - Выпадающее меню при использовании быстрого или полного редактирования

#newpm, #newpmheader - Для настройки уведомления о получении нового персонального сообщения

.editor_button,

.editor_buttoncl,

.editbclose, .editor_button_brk - Стили для настройки кнопок BB редактора при быстром редактировании новостей на сайте.

.editor - общий стиль для BB редактора.

.clouds_xsmall, .clouds_small, .clouds_medium, .clouds_large, .clouds_xlarge - Для настройки размеров различных ключевых слов в облаке тегов, в зависимости от их популярности

.highslide-active-anchor, .highslide-image-blur, .highslide-html-content, .highslide-loading, a.highslide-full-expand, .highslide-footer, .highslide-footer .highslide-resize, .highslide-resize, .highslide-display-block, .highslide-display-none - Для настройки показа всплывающего окна с оригинальным изображением из уменьшенной копии

.highslide-dimming - Используется для задания затемняющего фона при включении режима "Галереи" для показа загруженных изображений.

.mass_comments_action - оформление меню выбора действия над комментариями на сайте.

Не забудьте использовать данные стили в вашем главном шаблоне.


Общая информация

DataLife Engine позволяет использовать шаблонную систему для вывода новостей, а также для вывода различных модулей. Мы попытались максимально упростить использование шаблонов в движке, для того чтобы их использовать вам не надо обладать никакими знаниями языков программирования, только язык верстки HTML. Однако для более полного и легкого использования шаблонов мы рекомендуем вам внимательно прочитать руководство по работе с шаблонами, чтобы выяснить какие теги используются в шаблонах и для чего они предназначены.

Также вы можете подключать один шаблон в другой, используя тег {include file="my_block.tpl"} данный тег подключает указанный файл my_block.tpl в шаблон. Тег призван облегчить структуру шаблона, если используется сложная верстка со множеством тегов. Данный тег действует во всех шаблонных файлах .tpl Подключаемый файл должен находится в в той же папке что и другие файлы шаблона. Теги в подключаемом шаблоне должны быть такие же, какие допустимы в шаблоне где подключается файл, например если файл my_block.tpl подключается в шаблоне main.tpl, то и теги в этом файлы будут работать только те которые возможны в main.tpl

P.S. Единственное вам необходимо быть острожными при редактирования файла login.tpl. Он содержит PHP код и его нельзя отредактировать непосредственно в админпанели.


Главная страница сайта

Вывод данного раздела настраивается в файле main.tpl В этом разделе настраиваются шаблоны вашей главной и основной страницы, куда подключаются другие компоненты движка. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно.

{headers} | Выводит сгенерированные метатеги о кодировке страницы, title, keywords, description. Размещаеться в шаблоне между тегами <head>
{THEME} | Путь к выбранному шаблону
{login} | Вставка панели для входа и регистрации посетителей
{vote} | Вставка опроса на сайте
{changeskin} | Вставка формы для смены скинов на сайте
{calendar} | Вставка модуля календаря
{topnews} | Вывод самых рейтинговых статей
{archives} | Вывод архивов
{info} | выводит служебную информацию движка, в случае если возникла необходимость. Присутствие тега обязательно в шаблоне.
{content} | Вывод непосредственно самого контекста на сайте, новостей, обратной связи регистрации и прочего, в общем основная колонка. Присутствие тега практически обязательно в шаблоне, за исключением крайне редких случаев, в зависимости от необходимых возможностей самого сайта.
{custom} | Смотрите раздел "Вывод новостей на страницах"
[aviable=раздел]текст[/aviable] | Смотрите раздел "Вывод новостей на страницах"
{AJAX} | Подключает все необходимы скрипты для работы DLE и AJAX, подключение обязательно, и рекомендуется размещение в начале страницы, сразу после тега <body>
[group=X]текст[/group] | Вывод текста определенной группе пользователей. Где X это список ID через запятую группы пользователей.
[category=X]текст[/category] | Предназначен для вывода текста если пользователь находится в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую
{banner_имя} | этот тег предназначен для вывода рекламной информации на сайте. Само имя для баннера задается в специальном модуле в админпанели.
{inform_имя} | этот тег предназначен для вывода RSS информеров и новостей с других сайтов. Имя и все настройки для данного тега устанавливаются в админпанели скрипта.

[not-category=X]текст[/not-category]

Предназначен для вывода текста если пользователь находится везьде, кроме как в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую

[not-group=X]текст[/not-group]

Вывод текста любой группе пользователей, кроме указанной. Где X это список ID через запятую группы пользователей для которых непоказывать информацию.


Краткое содержание

Вывод кратких новостей настраивается в файле shortstory.tpl и возможно использование следующих тегов:

{title} | - Выводится заголовок статьи
{news-id} | - ID номер новости, это номер под которым данная новость храниться в базе данных
{short-story} | - Выводится краткая новость
{author} | - Автор статьи
{date} | - Дата публикации, формат вывода даты настраивается в настройках системы
{rating} | - Отображение рейтинга новости
{comments-num} | - Отображает количество комментариев , написанных к статье
{category} | - Категория, к которой относится статья
{category-icon} | - ссылка на иконку категории, внимание выводится именно путь к картинке, сам вывод вы должны предусмотреть самостоятельно например <img src="{category-icon}" />
{views} | - Количество просмотров новости
{favorites} | - Ссылка на добавление или удаление из Избранного
[edit] текст [/edit] | - Ссылка редактирование новости
{link-category} | - Ссылка на все категории в которой присутствует новость
[full-link] и [/full-link] | - Ссылка на полную версию, например [full-link]Подробнее…[/full-link]
[com-link] и [/com-link] | - Ссылка на комментарии к статье, выводится только если они разрешены
[xfvalue_x] | - Значение дополнительного поля "x", где "x" название дополнительного поля
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | - Выводится дополнительное поле "x", если поле не пустое, если поле не имеет значения, то текст просто вырезается
[group=X]текст[/group] | Вывод текста определенной группе пользователей. Где X это список ID через запятую группы пользователей.
[category=X]текст[/category] | Предназначен для вывода текста если пользователь находится в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую
[tags] текст [/tags] | Выводит текст если новость содержит ключевые слова, назначенные для облака тегов
{tags} | Выводит кликабельные ключевые слова новости
{full-link} | Для вывода полного постоянного адреса новости
[edit-date] текст [/edit-date] | выводит текст если новость была отредактирована
{edit-date} | выводит дату редактирования новости
{editor} | выводит логин пользователя, отредактировавшего новость
[edit-reason] текст [/edit-reason] | выводит текст если при редактировании была указана причина редактирования
{edit-reason} | выводит причину редактирования новости
{date=формат даты} | выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время
{approve} | Выводится только при просмотре пользователем собственного профиля и показывает статус его новостей ожидающих модерации
[fixed] текст [/fixed] | выводит текст в тегах если данная новость зафиксирована
[not-fixed] текст [/not-fixed] | выводит текст в тегах если данная новость не была зафиксирована
[day-news] текст [/day-news] | выводит ссылку на все новости, опубликованные в тот же день что и данная новость. Данный тег например можно использовать совместно с тегом {date}


Статья целиком

Вывод статьи целиком настраивается в файле fullstory.tpl и возможно использование следующих тегов:

{title} | - Заголовок статьи
{full-story} | - Полная версия
{short-story} | - Краткая версия новости
{author} | - Автор статьи
{date} | - Дата публикации
{pages} | - Навигация по страницам новости
{link-category} | - Ссылка на все категрии в которой присутствует новость
{rating} | - Выводится форма для выставления рейтинга статьи, тонкая настройка выводится производится при помощи CSS класса rating
{comments-num} | - Позволяет отображать количество комментариев к статье
{category} | - Категория, к которой относится статья
{category-icon} | - ссылка на иконку категории
{views} | - Количество просмотров новости
{favorites} | - Ссылка на добавление или удаление из Избранного
[edit] текст [/edit] | - Ссылка на редактирование новости
[print-link] и [/print-link] | - Ссылка на версию для печати
[com-link] и [/com-link] | - Ссылка на комментарии к статье только если они разрешены
[xfvalue_x] | - Значение дополнительного поля "x", где "x" название дополнительного поля
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | - Выводится дополнительное поле "x", если поле не пустое
[group=X]текст[/group] | Вывод текста определенной группе пользователей. Где X это список ID через запятую группы пользователей.
{related-news} | Выводить ссылки на 5 наиболее подходящих по контексту новостей.
[category=X]текст[/category] | Предназначен для вывода текста если пользователь находится в X категории. Где X это ID вашей категории. Допустимо перечислять категории через запятую
[tags] текст [/tags] | Выводит текст если новость содержит ключевые слова, назначенные для облака тегов
{tags} | Выводит кликабельные ключевые слова новости
{full-link} | Для вывода полного постоянного адреса новости
[edit-date] текст [/edit-date] | выводит текст если новость была отредактирована
{edit-date} | выводит дату редактирования новости
{editor} | выводит логин пользователя, отредактировавшего новость
[edit-reason] текст [/edit-reason] | выводит текст если при редактировании была указана причина редактирования
{edit-reason} | выводит причину редактирования новости
{poll} | Подключает шаблон с опросом для новости, если опрос был добавлен к новости.
{date=формат даты} | выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время
[fixed] текст [/fixed] | выводит текст в тегах если данная новость зафиксирована
[not-fixed] текст [/not-fixed] | выводит текст в тегах если данная новость не была зафиксирована
[day-news] текст [/day-news] | выводит ссылку на все новости, опубликованные в тот же день что и данная новость. Данный тег например можно использовать совместно с тегом {date}


Опросы в новостях

Вывод данного раздела настраивается в файле poll.tpl В данном разделе настраивается вывод опроса для опубликованной новости

{title} | - Заголовок опроса
{question} | - Вопрос
{votes} | - Общее количество голосов
{list} | - Список вариантов ответа
[voted] текст [/voted] | - выводят текст в тегах если пользователь уже проголосовал в опросе, в противном случае его скрывают
[not-voted] текст [/not-voted] | - выводят текст в тегах если пользователь еще не проголосовал в опросе, в противном случае его скрывают


Добавление новости

Вывод данной формы настраивается в файле addnews.tpl В этом разделе настраиваются шаблоны, которые используются при добавлении новости в базу данных со стороны посетителей сайта. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{category} | - выводится поле для выбора категории к которой будет принадлежать категория
{xfields} | - вывод дополнительных полей (подробнее о применении смотрите в тестовой шаблоне)
{bbcode} | - выводятся кнопки для вставки тегов в новости
{admintag} | - вывод дополнительных опций для администратора
[urltag] и [/urltag] | - выводится код заключенный в теги, для изменения ЧПУ URL статьи (доступно администратору)
[not-wysywyg] и [/not-wysywyg] | Выводится текст заключенный в теги если отключен WYSIWYG редактор, если включен, то содержимое тегов удаляется
{shortarea} | выводит WYSIWYG редактор для добавления краткой новости
{title} | Выводит заголовок во время редактирования новости
{alt-name} | Значение ЧПУ при редактировании новости
{short-story} | Короткая новость при редактировании новости
{full-story} | Полная новость при редактировании новости
[sec_code] и [/sec_code] | Выводит текст если было установлено в настройках использование CAPTCHA при добавлении новостей
{sec_code} | Код отображения CAPTCHA
{fullarea} | выводит WYSIWYG редактор для добавления полной новости


Комментарии

Вывод данного раздела настраивается в файле comments.tpl В данном разделе настраивается вывод комментариев для статьи.

{author} | - Имя человека, оставившего комментарий
{mail} | - Его е-mail или адрес веб страницы
{date} | - Дата публикации комментария, формат вывода даты настраивается в настройках системы
{comment} | - Текст комментария
{comment-id} | - Идентификационный номер комментария
{ip} | - IP адрес человека, оставившего комментарий
[com-edit] и [/com-edit] | - Ссылка на редактирование комментария только если это разрешено
[com-del] и [/com-del] | - Ссылка на удаление комментария только если это разрешено
{news_title} | - Выводит ссылку на новость при просмотре последних комментариев, при выводе комментариев в новости тег вырезается
{foto} | - Выводит ссылку на фотографию
{fullname} | - Выводит полное имя пользователя
{icq} | - Выводит номер ICQ
{land} | - Выводит место жительства
[signature] и [/signature] | - Выводит текст заключенный в теги, если пользователь задал подпись в профиле
{signature} | - Выводит подпись пользователя
{registration} | - Выводит дату регистрации на сайте
[fast] [/fast] | - Быстрое цитирование комментариев
{group-icon} | - выводит иконку группы участника
{group-name} | - выводит имя группы участника
{news-num} | - Выводит количество новостей участника
{comm-num} | - Выводит количество комментариев участника
{date=формат даты} | выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y H:i} выведет полную дату и время
{login} | выводит логин автора комментария без каких либо ссылок и меню
[profile] текст [/profile] | выводит текст заключенный в теге в виде ссылки на профиль пользователя оставившего комментарий
{mass-action} | устанавливает возможность массовой отметки комментариев для выполнения массовых действий на сайте


Форма добавления либо изменения комментария

Вывод данного раздела настраивается в файле addcomments.tpl В этом разделе настраиваются шаблоны, которые используются при добавлении комментариев в базу данных со стороны посетителей сайта. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{title} | - Выводит заголовок, для чего эта форма, для добавления или редактирования комментариев
[not-logged] и [/not-logged] | - выводится код заключенный в теги, если пользователь не зарегистрирован, например вы можете заключить в эти теги поля для ввода имени и e-mail адреса, если они не заполнены и пользователь авторизован на сайте, эти данные будут взяты автоматически из его профиля.
{editor} | выводит в зависимости от настроек BBCODE или WYSIWYG редактор для добавления комментария
[sec_code] и [/sec_code] | Выводит текст если было установлено в настройках использование CAPTCHA при добавлении комментариев
{sec_code} | Код отображения CAPTCHA


Предыдущая и следующая страницы для новостей

Вывод данного раздела настраивается в файле navigation.tpl В данном разделе настраивается вывод навигации для новостей

[prev-link] and [/prev-link] | - Создает ссылку на предыдущую страницу (если такая есть)
[next-link] and [/next-link] | - Создает ссылку на следующую страницу (если такая есть)
{pages} | - Создает ссылки на страницы; например: 1 2 3 4


Регистрация на сайте

Вывод данного раздела настраивается в файле registration.tpl В этом разделе настраиваются шаблоны, которые используются при регистрации посетителей на сайте. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

[registration] и [/registration] | - Выводит текст заключенный в тегах при регистрации
[validation] и [/validation] | - Выводит текст заключенный в тегах при активации
[sec_code] и [/sec_code] | - Выводит текст заключенный в тегах если разрешен показ кода безопасности
{reg_code} | - Выводит код безопасности для посетителя
{xfields} | Выводит поля для ввода дополнительных полей профиля


Информация о посетителе

Вывод данного раздела настраивается в файле userinfo.tpl В этом разделе настраиваются шаблоны, которые используются при выводе профиля пользователя. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{usertitle} | - Вывод имени пользователя
{info} | - Краткая информация о пользователе
{editmail} | - e-mail адрес
{comm_num} | - Количество комментариев
{news_num} | - Количество новостей
{status} | - Статус пользователя
{rate} | - Текущий рейтинг посетителя (складывается автоматически на основе рейтинга его статей)
{registration} | - Дата регистрации на сайте
{editinfo} | - Вывод существующей краткой информации в поле при редактировании профиля
{hidemail} | - скрытие e-mail адреса
{foto} | - выводит ссылку на загруженную фотографию
{fullname} | - выводит полное имя пользователя
{land} | - выводит место жительства
{icq} | - выводит номер ICQ
[not-logged] и [/not-logged] | - выводится код заключенный в теги, если пользователь который просматривает профиль и есть этот самый пользователь, используется для того чтобы посетители могли редактировать свой собственный профиль.
[signature] и [/signature] | - Выводит текст заключенный в теги, если пользователь задал подпись в профиле
{signature} | - Выводит подпись пользователя
{editsignature} | - Выводит отформатированную для редактирования подпись пользователя
{lastdate} | - Выводит дату последнего посещения сайта пользователем
{comments} | - Выводит ссылку на все комментарии этого пользователя
{allowed-ip} | Значение IP с которого разрешена авторизация
{xfields} | Список дополнительных полей профиля при их редактировании
[xfvalue_x] | - Значение дополнительного поля "x", где "x" название дополнительного поля
[xfgiven_x] [xfvalue_x] [/xfgiven_x] | - Выводится дополнительное поле "x", если поле не пустое
{group-icon} | - выводит иконку группы участника
[time_limit] [/time_limit]. | - выводит текст между тегами если пользователь находится во временной группе
{time_limit} | - выводит дату, до которой пользователь находится во временной группе
{news} | - Выводит ссылку на просмотр всех новостей данного пользователя
[rss] тект [/rss] | публикуют ссылку в профиле на RSS поток всех новостей пользователя.


Форма поиска

Вывод данного раздела настраивается в файле search.tpl В данном разделе настраиваются шаблоны, отвечающие за вывод формы поиска по сайту:

{searchtable} | - Форма поиска в виде таблицы
{searchmsg} | - Вывод сообщения о результатах поиска
[searchmsg] и [/searchmsg] | - Вывод текста в случае если был произведен поиск


Результаты поиска

Вывод данного раздела настраивается в файле searchresult.tpl В данном разделе настраиваются шаблоны, отвечающие за вывод новостей найденных в результате поиска:

{search-id} | Идентификационный номер найденного элемента
{result-date} | - Дата статьи
{result-title} | - Заголовок статьи
{result-author} | - Автор статьи
{result-text} | - Текст краткой новости
{result-comments} | - Число комментариев
[result-link] и [/result-link] | - Ссылка на статью
[searchposts] и [/searchposts] | - Вывод найденных результатов для новостей
[searchcomments] и [/searchcomments] | - Вывод найденных результатов для комментариев
[fullresult] и [/fullresult] | - Вывод результатов в виде статей
[shortresult] и [/shortresult] | - Вывод результатов в виде заголовков
[tags] текст [/tags] | Выводит текст если новость содержит ключевые слова, назначенные для облака тегов
{tags} | Выводит кликабельные ключевые слова новости
[edit-date] текст [/edit-date] | выводит текст если новость была отредактирована
{edit-date} | выводит дату редактирования новости
{editor} | выводит логин пользователя, отредактировавшего новость
[edit-reason] текст [/edit-reason] | выводит текст если при редактировании была указана причина редактирования
{favorites} | - Ссылка на добавление или удаление новости из Избранного
{edit-reason} | выводит причину редактирования новости


Статистика сайта

Вывод данного раздела настраивается в файле stats.tpl В данном разделе настраивается вывод общей статистики сайта

{datenbank} | - Общий размер базы данных
{news_num} | - Общее количество новостей
{news_allow} | - Опубликовано новостей
{news_main} | - Опубликовано на главной
{news_moder} | - Ожидает модерации
{comm_num} | - Количество комментариев
{user_num} | - Зарегистрировано пользователей
{user_banned} | - Забаненных пользователей
{topusers} | - Список лучших авторов на сайте
{news_day} | - Опубликовано новостей за сутки
{news_week} | - Опубликовано новостей за неделю
{news_month} | - Опубликовано новостей за месяц
{comm_day} | - Опубликовано комментариев за сутки
{comm_week} | - Опубликовано комментариев за неделю
{comm_month} | - Опубликовано комментариев за месяц
{user_day} | - Зарегистрировано пользователей за сутки
{user_week} | - Зарегистрировано пользователей за неделю
{user_month} | - Зарегистрировано пользователей за месяц


Вывод информации и ошибок

Вывод данного раздела настраивается в файле info.tpl В данном разделе настраивается вывод формы в случае возникновения ошибок, либо наоборот в случае успешного выполнения действий.

{title} – заголовок сообщения

{error} – текст ошибки


Форма для отправки E-Mail

Вывод данного раздела настраивается в файле feedback.tpl В этом разделе настраиваются шаблоны, которые используются при выводе формы для отправки E-Mail. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

{recipient} - Выводит список получателей

[not-logged] и [/not-logged] - Выводит текст между тегами если посетитель не зарегистрирован

{code} - Выводит код отображения CAPTCHA


Статические страницы

Вывод данного раздела настраивается в файле static.tpl В данном разделе настраивается вывод общей статистики сайта.

{description} выводит описание статической страницы

{static} выводит текст статической страницы

{pages} Навигация по нескольким страницам одной статической страницы

{custom} Смотрите раздел "Вывод новостей на страницах"

[print-link] текст [/print-link] выводить ссылку на версию для печати

{date} выводит дату создания страницы в формате установленном в настройках скрипта

{date=формат даты} выводит дату в заданном в теге формате. Тем самым вы можете выводить не только дату целиком но и ее отдельные части. Формат даты задается задается согласно формату принятому в PHP. Например тег {date=d} выведет день месяца публикации новости или комментария, а тег {date=F} выведет название месяца, а тег {date=d-m-Y, H:i} выведет полную дату и время. Также дополнительно как в тексте статических страниц, так и в их шаблонах вы можете указывать теги из модуля управления рекламой и теги информеров.


Персональные сообщения

Вывод данного раздела настраивается в файле pm.tpl В этом разделе настраиваются шаблоны, которые используются для работы с персональными сообщениями. Редактирование данного раздела не рекомендуется без знания HTML, потому что используется имена полей которые передаются в скрипт через форму, другими словами вы можете редактировать текст по своему усмотрению, но не изменяйте имена полей, это крайне важно. Возможно использование следующих тегов:

[inbox] и [/inbox] | - Ссылка на входящие сообщения
[outbox] и [/outbox] | - Ссылка на отправленные сообщения
[new_pm] и [/new_pm] | - Ссылка на написание сообщения
[pmlist] и [/pmlist] | - Выводится текст в тегах, если просматривается список сообщений
{pmlist} | - Список сообщений
[newpm] и [/newpm] | - Выводится текст в тегах, если написание сообщения
{author} | - Получатель сообщения
{subj} | - Тема сообщения
{editor} | выводит в зависимости от настроек BBCODE или WYSIWYG редактор для написания сообщения
{text} | - Текст сообщения
[readpm] и [/readpm] | - Выводится текст в тегах, если просматривается само сообщение
[reply] и [/reply] | - Ссылка для ответа на сообщение
[del] и [/del] | - Ссылка на удаление сообщения
{sec_code} | Код отображения CAPTCHA
[sec_code] и [/sec_code] | Выводит текст если было установлено в настройках использование CAPTCHA при написании персональных сообщений


Облако тегов

Вывод данного раздела настраивается в файле tagscloud.tpl В этом разделе настраиваются шаблоны, которые используются для работы с облаком тегов. В данном блоке показываются все ключевые теги добавленные к новостям.

Возможно использование следующих тегов:

{tags} - Используется для вывода всех ключевых тегов, находящихся в базе данных


Голосование на сайте

Вывод данного раздела настраивается в файле vote.tpl В этом разделе настраиваются шаблоны, которые используются для работы с голосованием на сайте.

Возможно использование следующих тегов:

{title} - Заголовок опроса

{list} - Список вопросов

{vote_id} - ID опроса

{votes} - Количество голосов

[votelist] и [/votelist] - Выводит текст который нужно показывать для еще не голосовавших людей

[voteresult] и [/voteresult] - Выводит текст который нужно показывать для уже голосовавших людей


Временное отключение сайта

В данном разделе вы можете настроить страницу, которая будет выводится при отключении сайта например на технические работы. Помните что администраторы всегда будут допущены к просмотру сайта как при включенном режиме. Все остальные будут видеть страницу из данного раздела.

Шаблон настраивается в файле offline.tpl и возможно использование следующих тегов:

{reason} - Используется для вывода причины отключения сайта, которое вы задаете в настройках скрипта


Модуль speedbar

В данном разделе вы можете настроить вывод текущего местоположения пользователя на вашем сайте. Данный шаблон использует только один тег {speedbar} который и выводит непосредственно местоположение.


RSS информер

В данном шаблоне вы можете настроить вывод вашего RSS информера. Имя данного шаблона вы назначаете самостоятельно в админпанели при добавлении нового RSS информера. В данном шаблоне вы можете использовать следующие теги:

[link] текст [/link] - формирует ссылку на новость партнера

{title} - заголовок новости

{news} - непосредственно сама новость

{category} - выводит категорию в которой опубликована новости в RSS потоке

{author} - выводит автора новости

{date} - выводит дату новости, при этом формат даты можно задать в настройках информера, для каждого информера


OpenSearch

Данный шаблон находится в файле templates/opensearch.tpl и предназначен для поддержки технологии OpenSearch в современных браузерах, данная технология позволяет интегрировать поиск по вашему сайту в строку поиска самого браузера. Будьте предельно внимательны при редактировании данного шаблона. Он должен соответствовать необходимым спецификациям.


Разработка и подключение модулей

DataLife Engine предоставляет удобные механизмы для подключения разработанных вами модификаций скрипта. Данные механизмы позволяют обеспечить работоспособность и после обновления скрипта на новую версию, т.к. данные механизмы позволяют осуществлять подключение без правки файлов скрипта. Для подключения разработанных вами модулей вам необходимо в любом необходимом вам шаблоне добавить тег:

{include file="engine/modules/mymod.php"}

Где engine/modules/ это путь к файлу вашего модуля, а mymod.php имя подключаемого файла. Стандартные файлы модулей DataLife Engine находятся в этой папке и мы вам рекомендуем использовать данную папку, однако это не является обязательным требованием и файл может находится в любой другой папке на сервере. Единственное ограничение безопасности по подобному подключению модулей, это то что на папку в которой находится файл не должно быть прав на запись (CHMOD 777). Также мы рекомендуем вам использовать именно относительные пути при подключении модулей, DataLfe Engine автоматически распознает относительные пути и подключает ваши модули уже согласно настройкам скрипта и путям где установлен скрипт. Тем самым вы можете создавать универсальные инструкции по установке ваших модификаций.

Также вы можете подключать PHP файлы вашего модуля передав в ваш PHP различные параметры, например:

{include file="engine/modules/mymod.php?param=value1&variable2=value2"}

Благодаря подобному подключению, вы можете делать ваши модификации многофункциональными, которые будут выполнять различные роли и функции при различных подключениях.

Начиная с версии DataLife Engine 8.3 в качестве параметров к подключаемым модулям вы можете задавать шаблонные теги скрипта, например при добавлении в шаблон полной новости конструкции {include file="engine/modules/mymod.php?param={news-id}"}, вы можете передавать вашему стороннему модулю в качестве параметра ID новости и т.д. Вниманию разработчиков: Передаваемые в скрипт параметры, это GET параметры, соответственно при выборе передаваемых тегов вы должны учитывать ограчения GET строки, другими словами вы не можете передать в качестве параметра содержимое полной новости к примеру.

Также вы можете использовать подключение своих модулей и для замены основного блока, где выводятся новости и другая основная информация, для этого необходимо использовать данный тег совместно с тегами [aviable=раздел]текст[/aviable] и [not-aviable=раздел]текст[/not-aviable] Описание тегов смотрите в документации в разделе "Вывод новостей на страницах". Вы можете использовать как стандартный список разделов, так и использовать создание собственного раздела сайта, передав его в URL браузера. Рассмотрим простейший пример. Вы хотите добавить к стандартным разделам сайта, добавить свой раздел и выводить информацию в нем из вашего модуля. Допустим вы хотите создать раздел FAQ. Для этого в шаблоне main.tpl прописывается конструкция:

[aviable=faq]{include file="engine/modules/mymod.php"}[/aviable]

[not-aviable=faq]{content}[/not-aviable]

После подобного подключения помимо работы стандартных разделов сайта при обращении по адресу: http://site.ru/index.php?do=faq вместо новостей будет выводится ваш новый раздел из вашего модуля.

Для работы ваших модулей и вывода информации именно в том месте шаблона, где вставлен вышеуказанный тег, обязательно только одно важное условие. Вывод информации должен осуществляется только через функцию PHP echo. Рассмотрим пример простейшего модуля и вывода информации. Создадим файл mymod.php со следующим содержимым:

<?php

echo "Тестовый модуль";

?>

При подключении этого файла в шаблоне, в данном месте шаблона появится текст: Тестовый модуль

Список переменных и классов DLE которые вы можете использовать в вашем подключаемом модуле, без дополнительного объявления:

$is_logged - содержит информацию, является ли посетитель авторизованным пользователем или гостем, и содержит значения true или false.

$member_id - содержит массив с информацией о авторизованном пользователе, включая всю его информацию из профиля.

$db - класс DLE для работы с базой данных.

$tpl - класс DLE для работы с шаблонами.

$cat_info - массив содержащий информацию обо всех категориях на сайте.

$config - массив содержащий информацию обо всех настройках скрипта.

$user_group - массив содержащий информацию о всех группах пользователей и их настройках.

$category_id - содержит ID категории которую просматривает посетитель.

$_TIME - содержит текущее время в UNIX формате с учетом настроек смещения в настройках скрипта.

$lang - массив содержащий текст из языкового пакета.

$smartphone_detected - содержит информацию о том, просматривает ли пользователь сайт со смартфона или с обычного браузера, и содержит значения true или false.

$dle_module - содержит информацию о разделе сайта, который просматривает пользователь, либо информацию переменной do из URL браузера.

Внимание: Ваш модуль должен только читать данные из данных переменных, внесение изменений в значения переменных повлечет сбои в работе стандартных возможностей скрипта и дальнейшей его некорректной работе.


Подключение модулей в адмипанели

DataLife Engine предоставляет удобные механизмы для подключения разработанных вами модификаций скрипта в админпанели. Данные механизмы позволяют подключать модули админпанели без внесения изменений в файлы скрипта и позволяют сохранять работоспособность после обновления скрипта на новую версию скрипта.

Для того чтобы подключить ваш сторонний модуль в админпанель, вы должны разместить файл вашего модуля в папке engine/inc/ это обязательное условие. Только файлы находящиеся в этой папке могут быть подключены. Например имя файла вашего модуля mymod.php вы разместили его в папке engine/inc/ После этого вы можете вызвать и обратится к вашему модулю из админпанели по адресу: http://site.ru/admin.php?mod=mymod где mymod это имя вашего модуля без расширения .php Подключение происходит автоматически, никаких изменений в файлах скрипта не требуется.

Для того чтобы пользователи не вводили адрес вашего модуля в браузере вручную и он отображался в списке всех разделов в административной панели, для этого предусмотрена специальная таблица в базе данных MySQL. Имя таблицы: ПРЕФИКС_admin_sections. ПРЕФИКС ваш скрипт установки может прочитать из файла engine/inc/dbconfig.php. Данная таблица содержит следующие имена полей:

name - содержит имя вашего модуля, а именно файла .php находящегося в папке engine/inc/, но без расширения файла. Например имя вашего файла mymod.php, то в данное поле должно быть записано значение mymod.

title - содержит заголовок вашего модуля.

descr - содержит описание вашего модуля.

icon - содержит имя иконки для вашего модуля, без указания пути. Иконка обязательно при этом должна находится в папке engine/skins/images/ (это обязательное условие). Рекомендуемые размеры иконок 70 на 70 пикселей.

allow_groups - содержит информацию о группах которым разрешен показ данного модуля. Данное поле может принимать следующие значения: all или ID групп через запятую. Например: 1,2,3. если указано значение all то модуль будет показываться всем пользователям имеющим доступ в админпанел.

Пример запроса для записи информации о модуле mymod:

INSERT INTO `префикс_admin_sections` (`name`, `title`, `descr`, `icon`, `allow_groups`) VALUES

('mymod', 'Тестовый модуль', 'Здесь находится описание тестового модуля', 'mymod.png', '1');

после выполнения данного запроса модуль в админпанели будет прописан в админпанели только для администраторов.

ВНИМАНИЕ: указание о группах в базе данных не запрещает и не предотвращяет запуск модуля пользователями из других групп. Для разграничения доступа ваши подключаемые модули обязаны сами производить проверку групп и разрешать выполнение только разрешенным группам.


API для разработки модулей

API предназначен для написания модификаций совместимых со старыми и будущими версиями скрипта. В случае использования API для получения данных из базы, вы можете быть уверенными что данный код будет работать и в будущих версиям, тем самым вы облегчается проверка и адаптация кода при выходе новой версии. Также при использовании API вам нет необходимости писать собственные функции для выборки данных, нет необходимости подключать и объявлять необходимые для работы с БД классы. Достаточно просто подключить файл API, и начать использовать его функции, все остальное он берет на себя.

Для использования API в своем модуле вы должны его подключить строчкой:

include ('engine/api/api.class.php');

При этом вам нет необходимости задумываться есть ли подключение к БД или нет, подключены или нет необходимые классы. Данный код вы можете использовать как внутри файлов самого скрипта DLE, так и просто в других скриптах, не имеющих отношения к DLE. Тем самым вы можете организовывать стандартизированные интеграции скрипта DLE, с другими скриптами. Например форумами.

Список функций API:

$dle_api->take_user_by_id( int $id [, string $select_list] );

получение массива с информацией о пользователе по его ID. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить или * для всех. Возвращает массив с информацией о пользователе либо false, если пользователь не найден.

$dle_api->take_user_by_name( string $name [, string $select_list]);

получение массива с информацией о пользователе по его логину. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить или * для всех. Возвращает массив с информацией либо false, если пользователь не найден.

$dle_api->take_user_by_email( string $email [, string $select_list]);

получение массива с информацией о пользователе по его E-Mail. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить или * для всех. Возвращает массив с информацией либо false, если пользователь не найден.

$dle_api->take_users_by_group( int $group_id [, string $select_list [, int $limit]]);

получение массива с информацией о пользователях по номеру группы. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить. Необязательный параметр $limit указывает на лимит количества возращаемых пользователей. Возвращает массив с информацией либо false, если пользователи не найдены.

$dle_api->take_users_by_ip( string $ip, [, bool $like [, string $select_list [, int $limit]]]);

Получение списка пользователей по IP, второй параметр $like указывает использовать точное совпадение при поиске, либо неточное. Необязательный параметр $select_list указывает на перечень полей БД которые необходимо получить. Необязательный параметр $limit указывает на лимит количества возращаемых пользователей. Возвращает массив с информацией либо false, если пользователи не найдены.

$dle_api->change_user_name( int $user_id, string $new_name);

Изменение логина пользователя. user_id ID пользователя, логин которого необходимо заменить. new_name новый логин пользователя. Возвращаемые значения: true если успешно выполнено, false если новое имя уже занято другим пользователем.

$dle_api->change_user_pass( int $user_id, string $new_pass);

Изменение пароля пользователя. user_id ID пользователя, пароль которого необходимо заменить. new_pass новый пароль пользователя.

$dle_api->change_user_email( int $user_id, string $new_email);

Изменение E-Mail пользователя. user_id ID пользователя, E-Mail которого необходимо заменить. new_email новый E-Mail пользователя. Возвращаемые значения: 1 - успешно выполнено, -1 - новый E-Mail уже существует, -2 - некорректный E-mail.

$dle_api->change_user_group( int $user_id, int $new_group);

Изменение группы пользователя. user_id ID пользователя, группу которого необходимо заменить. new_group ID новой группы пользователя. Возвращаемые значения: true если успешно выполнено, false если указан ID несуществующей группы.

$dle_api->external_auth( string $login, string $password);

Авторизация по логину и паролю. Возвращаемые значения: true - авторизация успешна, false - логин или пароль не верны.

$dle_api->external_register( string $login, string $password, string $email, int $group);

Регистрация пользователя в базе данных. В функцию передаются: Логин, Пароль, E-mail и номер группы в которой зарегистрировать пользователя. Возвращаемые значения: 1 - успешно выполнено, -1 - новый логин уже существует, -2 - новый E-Mail уже существует, -3 - некорректный E-Mail, -4 - задана несуществующая группа.

$dle_api->send_pm_to_user ( int $user_id, string $subject, string $text, string $from);

Отправка персонального сообщения пользователю. $user_id ID получателя. $subject тема сообщения. $text текст сообщения. $from логин отправителя. Возвращаемые значения: 1 - успешно выполнено, -1 - получатель не найден, 0 - ошибка БД.

$dle_api->load_table ( string $table [, string $fields [, string $where [, bool $multirow [, int $start [, int $limit [, string $sort [, string $sort_order]]]]]]]);

Получение информации из таблицы БД.

$table - название таблицы

$fields - необходимые поля через запятую или * для всех

$where - условие выборки

$multirow - забирать ли один ряд или несколько

$start - начальное значение выборки

$limit - количество записей для выборки, 0 - выбрать все

$sort - поле, по которому осуществляется сортировка

$sort_order - направление сортировки

Возвращается массив с данными, либо false если в БД по указанным параметрам ничего не найдено.

$dle_api->save_to_cache ( string $fname, mixed $vars);

Запись данных в файл кеша. Параметр $fname указывает имя файла кеша без указания его расширения. $vars - данные для записи в кеш.

$dle_api->load_from_cache ( string $fname, [, int $timeout [, string $type]]);

Чтение данных из файла кеша. Параметр $fname указывает имя файла кеша без указания его расширения. Необязательный параметр $timeout указывает количество секунд, в течении которых информацию из кеша считать актуальной. Если файл кеша будет устаревшим, то функция возвращает false. Необязательный параметр $type указывает на тип данных который хранится в кеше, если не 'text' - считаем, что хранился массив и возвращается массив данных.

$dle_api->clean_cache ( [string $name] );

Удаление кеша. Необязательный параметр $name указывает на конкретное имя файла без расширения который нужно удалить

$dle_api->get_cached_files();

Получение массива содержащего названия файлов кеша.

$dle_api->edit_config ( mixed $key, [, string $new_value]);

Изменение и сохранение настроек скрипта.

Параметр $key string или array

string: Название параметра

array: ассоциативный массив параметров

Параметр $new_value - значение параметра. Не используется, если $key массив

$dle_api->take_news ( string $cat, [, string $fields [, int $start [, int $limit [, string $sort [, string $sort_order]]]]]);

Получение новостей

$cat - категории новостей, через запятую

$fields - перечень получаемых полей новостей или * для всех

$start - начальное значение выборки

$limit - количество новостей для выборки, 0 - выбрать все новости

$sort - поле, по которому осуществляется сортировка

$sort_order - направление сортировки

Возвращает ассоциативный 2-х мерный массив с новостями

$dle_api->checkGroup ( int $group );

Проверяет существует ли указанная группа или нет. Возвращаемые значения: true если группа существует, false если группа не существует.

$dle_api->install_admin_module ( string $name, string $title, string $descr, string $icon [, string $perm] );

Установка стороннего модуля в админпанель скрипта.

$name - название модуля, а именно файла .php находящегося в папке engine/inc/, но без расширения файла

$title - заголовок модуля

$descr - описание модуля

$icon - имя иконки для модуля, без указания пути. Иконка обязательно при этом должна находится в папке engine/skins/images/

$perm - информация о группах которым разрешен показ данного модуля. Данное поле может принимать следующие значения: all или ID групп через запятую. Например: 1,2,3. если указано значение all то модуль будет показываться всем пользователям имеющим доступ в админпанель

$dle_api->uninstall_admin_module ( string $name );

Удаление стороннего модуля из админпанели скрипта.

$name - название удаляемого модуля

$dle_api->change_admin_module_perms ( string $name, string $perm );

Изменение группы пользователей которым разрешен показ стороннего модуля в админпанели скрипта.

$name - название модуля

$perm - информация о группах которым разрешен показ данного модуля. Данное поле может принимать следующие значения: all или ID групп через запятую. Например: 1,2,3. если указано значение all то модуль будет показываться всем пользователям имеющим доступ в админпанель

Разработка полноценного API, только начата и на данный момент API имеет пока ограниченный набор функций. Поэтому мы просим всех заинтересованных в данном API разработчиков посетить специально созданную для этого тему на форуме и оставить свои пожелания о том какие новые функции вы хотите видеть в новых версиях. Потому что только опираясь на ваши потребности можно создать полноценный API, охватывающий все аспекты взаимодействия с скриптом.


Автоматически бекап БД

Начиная с версии 6.5 в DataLife Engine присутствует функция создания автоматического бекапа базы данных MySQL. Для создания бекапа в автоматическом режиме вам необходима поддержка вашим хостингом функции запуска приложений по расписанию (CRON). Для создания резервной копии БД предназначен файл autobackup.php расположенный в корне вашего сайта. По умолчанию в целях безопасности возможность создания резервных копий отключена, поэтому рассмотрим как можно включить данную функцию.

Во первых мы рекомендуем обязательно в целях безопасности изменить название файла autobackup.php на любое другое с расширением .php

Далее откройте этот файл в текстовом редакторе и в самом начале найдите строчку

$allow_auto_backup = 0;

Измените ее на

$allow_auto_backup = 1;

Тем самым вы разрешаете этому файлу создание резервных копий в автоматическом режиме.

Далее вы можете изменить количество файлов резервных копий которые будут хранится на сервере. Для этого найдите чуть ниже строчку

$max_count_files = 5;

где 5 это количество копий БД. Вы можете поставить свое собственное количество файлов. При превышении данного лимита более старые резервные копии базы данных будут автоматически удалятся.

После того как вы произвели необходимые изменения, сохраните данный файл на сервере. Теперь вам нужно добавить данных файл на запуск по расписанию (CRON) время создания и периодичность вы устанавливаете самостоятельно. Подробную инструкцию по добавлению данного файла в функцию CRON вы можете получить у вашего хостинг провайдера.


RSS Экспорт

Движок DataLife Engine поддерживает также экспорт новостей в формате RSS для того чтобы посетители получили экспорт новостей с главной страницы вы должны использовать следующий путь.

http://website.com/rss.xml - с использованием ЧПУ

http://website.com/engine/rss.php - без использования ЧПУ

Для экспорта новостей из определенной категории используйте следующие ссылки

http://website.com/альтернативное имя/rss.xml - с использованием ЧПУ

http://website.com/engine/rss.php?do=cat&category=альтернативное имя - без использования ЧПУ

Для экспорта всех новостей определенного пользователя используйте следующие ссылки

http://website.com/user/имя пользователя/rss.xml - с использованием ЧПУ

http://website.com/engine/rss.php?subaction=allnews&user=имя пользователя - без использования ЧПУ